Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When selecting the volume in the installation program it says "You cannot install Merucrial on this volume. Mercurial requires Apple Python 2.6". I tried installing the latest version of Python from python.org but no luck.

Regards

Peter

share|improve this question

1 Answer 1

Most likely the python you installed from python.org is installed but the path it is in is not where mercurial for Mac is looking. Try the command which python to see which path to python is found.

The best way to get python 2.6 on MAC in a place that MAC apps can find it is sudo port install python26 on the command line and that will do the trick.

share|improve this answer
    
Opened terminal, typed the command sudo port install python26 and get the error sudo: port: command not found Is the python26 you are referring to something I need to download? I downloaded the python DMG which has a .mpkg file in it. –  user31608 Mar 19 '10 at 4:23
1  
Sorry about that. Port is a package install system - it needs to be installed itself - here is the link macports.org –  Jeremy Hajek Mar 19 '10 at 4:30
    
$ which python /Library/Frameworks/Python.framework/Versions/2.6/bin/python After installing Port... $ sudo port install python26 Error: Unable to open port: can't read "build.cmd": Failed to locate 'make' in path: '/opt/local/bin:/opt/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin' or at its MacPorts configuration time location, did you move it? Before reporting a bug, first run the command again with the -d flag to get complete output. –  user31608 Mar 19 '10 at 4:51
    
Looks like this is now a duplicate thread - the answer to your exact situation is here: superuser.com/questions/67483/… –  Jeremy Hajek Mar 19 '10 at 4:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.