Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a NETGEAR WGT624 wireless router at home which dies when there is a heavy torrent load.

I open up my torrent client and it downloads for about 5 to 10 minutes and it continues to increase the number of seeds (goes up to 70-80 seeds), but after that the router simply fails and I have to restart it in order to get an internet connection again.

When I connect directly via an ethernet cable the router and open up the torrent client, then it seems to be doing fine, but when I go wireless then the router stops working properly (although all the lights are still blinking as normal).

Is there any way that I can fix this? New router firmware? Change some router options? Feed it a cookie? Anything?

share|improve this question

migrated from serverfault.com Mar 19 '10 at 6:09

This question came from our site for system and network administrators.

1  
@lirik, is that an obscure reference to hackers? –  Mark Henderson Mar 18 '10 at 22:04
    
@Farseeker unintentionally... but if it brings you to a simpler time when you were younger and more gullible, when you thought that Zero Cool and Acid Burn were l33t names, and your idea of a hacker attack was pacman eating the garbage file, then yes... sure :). –  Lirik Mar 18 '10 at 22:12
    
@lirik, I honestly only saw that movie for the first time maybe 5 years ago, after seeing Hackers 2 (the Kevin Mitnick one). It was comical, and now I can see where everyone gets their crazy ideas about hackers from. And you got to see Angelina Jolie's boobies (before she was famous)! –  Mark Henderson Mar 18 '10 at 22:36

3 Answers 3

up vote 2 down vote accepted

Looked like user37899 beat me too it as I got pulled away from my desk but as he stated. Torrents tend to create a lot of tcp sessions which are stored in the state table on your router. It sounds like your state table is filling up and unable to handle any new sessions.

Sessions get removed from the state table in one of two ways. Either the session is closed normally or the session times out after a set period of no activity.

So there are 4 ways to fix this, these may not all be supported on your router.

  • Lower the tcp timeout on your router.
  • Increase the size of the session table.
  • Look into 3rd party firmware such as tomato or dd-wrt.
  • Get a better router.
share|improve this answer
    
The first two options are not available for my router, but I'll probably try dd-wrt... I just hope I can revert back to the factory firmware if something goes wrong. If all else fails then it might be time for a router upgrade. –  Lirik Mar 19 '10 at 0:46
    
Since DD-WRT doesn't look to be a promising option, perhaps look here smallnetbuilder.com/component/option,com_chart/Itemid,189 for high throughput routers. The WNDR3700 seems to get high marks around the web. –  hyperslug Mar 24 '10 at 2:37

Torrent programs can open up lot of tcp connections, which can can consume a great deal of memory and cpu resources. You maybe just exceeding the amount of connections the router can handle. NAT needs to keep track of every connection across the router. Many routers are just about powerful enough to handle web browsing, if you start using torrents, then you could well be exceeding the routers capabilities.

When your using wireless, you probably using more cpu and memory resources for those types of connections, so this is making the problem worse.

Can you get any logs or diagnostics from the router?

Solutions.

Upgrade your router to something more powerful.

Turn off NAT on your router (only some support this) and place your machine in the DMZ. (you'll also have no firewall beware!)

Add a PC as your gateway (perhaps pfsense), should be able to handle 1000's NAT of connections.

Limit the number of tcp connections your torrent software can make.

You may be able to limit the number of tcp connection each client can make on the router itself.

Good Luck!

share|improve this answer
2  
also feed it a cookie :-) –  Anonymous Mar 18 '10 at 21:55
    
@user37899 I sensed some reluctance when I tried to feed it a cookie... but threatening to disconnect the power cord was persuasive enough to make it eat the cookie. :) –  Lirik Mar 18 '10 at 22:05

I had to go out and get a better router to resolve this. The linksys WRT54Gv5 couldn't handle all the connections I needed. I had to go to a Linksys WRT54GL that has more memory and can handle more connections. If you want to stick with Netgear look at a WGR614L.

Both the Linksys WRT54GL and the Netgear WGR614L are able to run DD-WRT which adds extra functionality.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.