Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Abit AB9 QuadGT motherboard which has a SATA-II controller.

Connected to it I have a Kingston SSDNow V Series 64GB as boot drive and a Seagate Barracuda 7200.10 as a data drive. I also have 2 x Optiarc AD-7170S DVD burners attached by SATA.

Both SSD and HDD are SATA-II and the optical drives are SATA-I.

I have just run CrystalDiskInfo and this is reporting that both SSD and HDD are the SSD is connected at SATA-I (1.5 Gbps), not SATA-II (3.0 Gbps).

I have the BIOS set up to use SATA drives in IDE mode.

So a few questions:

  1. Is CrystalDiskInfo reporting correctly? - yes it is!

  2. Are the optical drives causing the SSD & HDD to connect at the slower rate? - no they are not!

  3. Is there any setting or jumper to force the SSD & HDD to use SATA-II?

I'm running Windows 7 Ultimate.

EDIT: More info: I have now run CrystalDiskInfo on my Media Centre PC and it is reporting the same model Kingston SSD as SATA-I but the data drive WD Caviar Green correctly as SATA-II

EDIT2: Thanks to Michael Steele - I now have a SATA-II mode data HDD! Now it's just the SSDs to sort out

EDIT3: See my answer below - the SSD is supposed to be in SATA-I mode.

share|improve this question
    
Have you tried switching/is it possible to switch to AHCI mode in your BIOS? There are potential benefits: en.wikipedia.org/wiki/Advanced_Host_Controller_Interface –  sblair Mar 20 '10 at 0:27
    
@sblair: I used IDE mode because when I first built the PC the general feeling was that AHCI was more suited to server systems and would actually cause slow downs on general usage PCs. Is this info now out of date? –  Shevek Mar 20 '10 at 9:50
    
@sblair: Also, will changing from IDE to AHCI require an OS reinstall? –  Shevek Mar 20 '10 at 9:50
    
@sblair: I just followed support.microsoft.com/kb/922976 to enable the AHCI driver in Windows - I'm about to reboot and change mode... Wish me luck! Hopefully I will be back again sooner rather than later :) –  Shevek Mar 20 '10 at 10:30
    
well, that didn't work, changing to AHCI gives me a BIOS error: NO BOOT DEVICE FOUND :( Back on IDE mode now. –  Shevek Mar 20 '10 at 10:40
add comment

2 Answers 2

up vote 3 down vote accepted

Seagate Barracuda 7200.10

There is a jumper block on the back of the drive next to the power and data connections. By default, a jumper is set to limit the drive to SATA-I speeds.

share|improve this answer
    
waita.... the jumper is set by default?? that doesn't make any sense. (and while it would explain the hdd behavior, it doesn't explain why the SSD isn't running at SATA-II speeds.) –  quack quixote Mar 19 '10 at 21:14
    
The drive's speed is limited by default in order to be compatible with older motherboards which don't support SATA-II. I'm unable to comment on your SSD. Check the documentation for anything similar. –  Michael Steele Mar 19 '10 at 21:36
    
Spot on, the seagate had a jumper which I removed and its now in SATA-II mode! Many thanks –  Shevek Mar 20 '10 at 12:05
add comment

I've just had this response from Kingston Support:

V series generation 1 products were not fast enough to take advantage of the SATA II. This is the reason why they are seen as SATA I.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.