Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Abit AB9 QuadGT motherboard and am trying to swap over to AHCI mode.

I have an existing Windows 7 installation which was installed under IDE mode.

I have set the msahci registry setting to 0.

When I try to boot in AHCI mode I get "DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER".

I have tried booting with my Win 7 DVD in the optical drive.

There is 1 SSD (System), 1 HDD (Data) and 2 optical drives connected via SATA

If I switch back to IDE mode everything boots fine, either from the SSD or from a CD or DVD in the optical drive.

Why can't I use AHCI mode?

UPDATE: June 2012 - After buying 2 new faster SSD drives I had another go at this. I discovered I had a buggy BIOS version and a later version fixed the AHCI issue. Abit went out of business in 2009 so for anyone who is still using one of these boards and has the same issue, I include a link here to the page where I found the later BIOS:

http://www.lejabeach.com/ABIT/AB9QuadGT/

share|improve this question

2 Answers 2

up vote 1 down vote accepted

This sounds like a BIOS error -- the BIOS isn't finding the right drive to boot from when in AHCI mode. I do not believe you're dealing with an OS issue.

Try stripping the system down to bare minimums.

  • Plug in only one bootable hard drive (the HDD or SSD, whichever contains the OS system partition) and no optical drives and try booting.

  • Plug in only one optical drive and no harddrives and try booting. If it doesn't work, disconnect and try the other optical drive.

  • Plug in only one bootable hard drive and one optical drive. You should be able to boot to the hard drive and the DVD.

When trying to boot from a single device, make sure you try all SATA ports on the motherboard before giving up.

If you can boot in those situations, your problem is the ports you've connected your drives to -- try rearranging them so they connect to different ports, to force the BIOS to enumerate them in the correct order.

If you can boot to the optical drive but not the hard drive, you may have a broken bootloader (eg, if the bootloader is installed to the non-system drive's MBR but not the system drive's MBR). You should be able to fix this from the Win-7 repair console.

If none of those work, make sure you have the latest BIOS firmware and try again. You may need to try resetting the BIOS to defaults and reselecting AHCI mode.

share|improve this answer
    
thanks ~quack, I'll try all this when I have a spare hour later on today. –  Shevek Mar 20 '10 at 14:14
    
@~quack: I tried to default the bios and set back to ACHI but I still get the error. I'll try the port swapping next. Is there any easy way to tell which of the drives has the bootloader on it? –  Shevek Mar 21 '10 at 11:03
    
@Shevek: just try them one at a time. the drive with the OS system partition should have the bootloader too. –  quack quixote Mar 21 '10 at 12:27
    
after 2+ years I've finally cracked this one! I discovered that I had an old BIOS version which had buggy AHCI code. Updated to the latest (no mean feat considering Abit went out of business 3 years ago!) andI now have a fully functional AHCI controller. My 2 x SSD drives are now running ~25% faster. I've now accepted your answer as you suggested it was BIOS all those moons ago :) –  Shevek Jun 19 '12 at 19:02

After reading this article about SSD performance on IDE vs AHCI mode, I will stick with IDE mode for now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.