Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Although my machine resumes from sleep very quickly, the network access takes quite a few seconds. Why should this be?

I have specified fixed IPs, hardcoded the DNS and gateway settings.

Any clues as to how i can speed this up?

share|improve this question
    
Wireless or Wired? –  Jason R. Coombs Mar 28 '10 at 13:22
    
I have found that the network switch was causing issues with restriction certain types of traffic. Once i had disabled these it worked fine. –  jamie Nov 7 '10 at 9:29
add comment

5 Answers

how is your networkhardware defined? does it stay online during sleep or is it set to power off? The first possibility would enable wake on network the second takes longer to come up from sleep.

share|improve this answer
add comment

Check whether this also happens when you plug in the network cable. The NIC may have problems initiating the physical connection with the switch/router/whatever you have on the other end.

share|improve this answer
    
i'll give that a go. –  jamie May 12 '10 at 10:20
    
It would appear to be the Linksys switch. When i plug the network came directly into the firewall / router box instead we get pretty much instantaneous network access. –  jamie Jun 18 '10 at 10:28
add comment

I have a netbook that takes closer to 30-60 seconds for the wireless to reconnect when waking from sleep mode. I'd say a few seconds is negligible.

The only thing I would suggest is to see if the "Allow the computer to turn off this device to save power" is selected in the Adapter Properties window.

I believe that is only an option for wireless adapters.

share|improve this answer
add comment

just a thought, if you are in a domain and your server is handling dns make sure that your dns points to the server, if it points to an outside dns address it make take a while for it to log in.

share|improve this answer
add comment
up vote 0 down vote accepted

I have found that the network switch was causing issues with restriction certain types of traffic. Once i had disabled these it worked fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.