Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i have installed Apache Tomcat6 for Ubuntu 9.04 recenty. But it seems that some API's like servelet and http are not included although I have installed OpenJDK 1.6.

Somebody advised me to set JAVA_HOME path variable. But I don't know how or where to make that change. Can someone please explain the procedure?

share|improve this question
add comment

1 Answer

You should take a look at this guide. and this

I think you've installed jre, jdk and downloaded tomcat.

Then extract, and move tomcat folder to a permanent location as u like : for example ,

sudo mv apache-tomcat-6.0.14 /usr/local/tomcat 

okay, Tomcat requires setting the JAVA_HOME variable. The best way to do this is to set it in your .bashrc file. You could also edit your startup.sh file if you so chose.

The better method is editing your .bashrc file and adding the bolded line there. You’ll have to logout of the shell for the change to take effect.

vi ~/.bashrc

Add the following line:

export JAVA_HOME=/usr/lib/jvm/java-6-sun 

At this point you can start tomcat by just executing the startup.sh script in the tomcat/bin folder.

share|improve this answer
    
I'll care more , Thank anyway –  Ye Lin Aung Mar 23 '10 at 7:21
    
much better, thanks! :) –  quack quixote Mar 23 '10 at 21:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.