Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Firefox with NoScript to stop the bad stuff. I've also told Acrobat Reader to load .pdf files in it's own window instead of inside the browser (because sometimes it locks up, and then I would have to restart the browser). However, whenever I come across a .pdf file, I always get a new tab completely covered by the NoScript box. Then, I can click anywhere in that page, and NoScript asks me if I'm sure I want to allow it. Then, Acrobat Reader is launched in its own window, but the Firefox tab remains, and I have to close it. It seems like NoScript is getting in the way of Acrobat's attempt to just open the file without making a new tab. Is there a way to tell NoScript to always allow .pdf files (Or any other suggestion to make that annoying blank tab go away by itself)?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

The NoScript Features document says:

You can configure some exception to the Forbid Other Plugins option by setting the noscript.allowedMimeRegExp about:config preference to a pattern matching the content types you want to allow. For instance, setting it to "application/pdf" will let PDF document load automatically on every site.

share|improve this answer
    
This is what I was looking for, but unfortunately, it doesn't fix the annoying blank tab. Oh well. Thanks. –  Ben Mar 22 '10 at 19:19
add comment

You can use FlashGot and Alt + Click on the link to download it.

I'm not sure how this will affect opening the file in Adobe.

You can go into NoScript's Options and uncheck the Ask for confirmation before unblocking box.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.