Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There are a bunch of forum posts about this issue from the last several years but no resolution that I could find. I have the newest VLC installed on Windows 7 with the newest nvidia drivers. Suddenly, VLC plays some videos in such a way as faces are blue. When viewed in another media player, or when looking at the thumbnails, this is not an issue. Other videos are not affected.

I've tried resetting VLC options, deleting the VLC folder in the AppData area, etc. I have no other color issues. Does anyone have a fix?

share|improve this question
1  
When it happens, is it just faces (ie, building look normal) or does everything in the video look that way? When it happens, is it just the video (eg the desktop and other windows look normal) or does everything look that way? –  Synetech Feb 6 '12 at 3:33
    
@Synetech: R and B swap around, this is a problem between hardware acceleration and a codec. –  Tom Wijsman Jul 12 '12 at 20:48
    
@TomWijsman, and it affects only faces but not other things in the frame? That's a very strange acceleration-codec problem. (It sounds more like a frayed video-cord; I remember when my monitor's cord had a problem and everything looked purple-blue because the green wire had a bad connection.) –  Synetech Jul 12 '12 at 21:00
    
@Synetech: No, everything. It's most recognizable in faces because they contain a lot of red. –  Tom Wijsman Jul 12 '12 at 21:00
1  
That's not a bug, that was just a capture from the Smurfs movie. :-D –  Synetech Jul 12 '12 at 21:15
show 2 more comments

2 Answers

It's a bug in the video drivers. Just go to VLC settings and change the video output type until it works.

share|improve this answer
    
This has nothing to do with the video drivers, they just show what you give to them. If you give it wrong, however... –  Tom Wijsman Jul 12 '12 at 20:49
add comment

This is the issue...

A bug causes the effect on graphic card drivers, video files for all players, and even Flash players.

For the browsers, if you are seeing this issue in Flash, just right-click on the Flash player and disable hardware acceleration. If you are seeing the issue in VLC, just go through the video preferences and colors tab to change the color.

Otherwise it is a bug effecting all video players.

If you have the best display drivers, reboot into safe mode, uninstall the display driver, after which you will need to install a new display driver and restart.

Check out this similar question over at askubuntu.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.