Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I double-click on the FF icon to open Firefox, a Chinese website loads up in one of the tabs.

Checking my settings for startup homepage (Tools > Options) it was set to Google.

Can anyone please advise how can I remove the uninvited Chinese website from loading every time I open Firefox?

I am using Windows 7 64 bit with Firefox as my default web browser.

share|improve this question

3 Answers 3

up vote 0 down vote accepted

If you right click on the shortcut icon and select "Properties ..." do you see the URL for the Chinese website anywhere in the text fields on the Properties page?

share|improve this answer
    
Yes, you are right, I saw in the properties: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" 2888.me, I tried to change it and save it, but there's error prompting: "You will need to provide Administrator permission to change this settings." How to fix this? Thanks. –  user31788 Mar 23 '10 at 8:41
    
The message says that you need to use an account with Administrator access rights to change the properties of the shortcut. Perhaps the shortcut is owned by an Administrator or another user. If you don't know the password for an account with permission to modify this file, you will need to ask someone who does to fix this for you. It is also worth checking in the Security tab on the Properties page to see if you can give yourself Modify or Full control permissions. Sometimes, even if you own the file, you don't have permission to modify the file without explicitly changing the permissions. –  richj Mar 23 '10 at 10:25
  1. Browse to the site you'd like as your homepage (e.g. Google).

  2. Drag the "favicon" from the left-hand end of the address bar and drop it on your Home icon (the one that looks like a little house).

Alternatively:

From the menu bar: Tools > Options
"General" tab
Paste the address into the Homepage text field, or just click the Use Current Pages button.

But you should also consider what else may have been changed in your Firefox profile...

share|improve this answer

If it doesn't appear in your list of homepage tabs, try looking for any suspicious add-ons; I once saw a computer that hijacked all google results to some advertising page, and it turned out that an add-on to firefox called "XUL Optimizer" was the rogue causing this.

share|improve this answer
    
I didn't see any suspicious addons on my list, only those that i manually downloaded from firefox site. –  user31788 Mar 23 '10 at 8:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.