Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have tried both IDE and AHCI modes in the BIOS. Also tried many different driver revisions.

I can't seem to hot swap an external SATA drive. I can use the wizard to safely remove it, but reconnecting doesn't do anything unless I reboot. I use a thermaltake dock, and I would like to swap in my backup drive sometimes to do images (they take all day over USB). I can reboot, but I'd like to use hot swap.

The controller is a Jmicron JMB363. I'm using the latest BIOS on my motherboard, as well.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Hotplugging is a basic SATA feature but proper support requires the device to be running in native command mode (AHCI), not with IDE emulation. So your BIOS (or at least the controller, if the controller is not on the motherboard) needs to be set to AHCI mode. Proper hotplug support also includes a proper SATA power connector.

According to this 2008 Tomshardware post, the JMicron JMB363 chipset supports hotplugging but the manufacturer's drivers don't. The poster recommends using a 3rd-party software called HotSwap (original link, broken) to enable this functionality.

According to a SiliconImage knowledgebase article linked from HotSwap's homepage, you may need to make sure the drive is powercycled (unplug the power cable) before reattaching the eSATA data cable.

I have not used this tool before; investigate it for yourself before installing unknown software.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.