Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I seem to be missing drivers for my Gateway laptop MA7. I have looked in System->Admin->Hardware Drivers, but it does not show up in there.There are also no devices listed in Sound->Hardware. I'm guessing at this point that I don't have the driver installed.

However, I get the following output:

admin@machine001:~$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xd8240000 irq 22

And my lspci shows:

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8038 PCI-E Fast Ethernet Controller (rev 14)
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
04:09.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
04:09.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
04:09.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)

I have also checked alsamixer, and nothing is muted. No headphones plugged into headphone jack either.

So the question now is, how do I get sound to work on my laptop? It doesn't work for any application.

Update: I have run alsa-info, and it is located at

I have tried to edit the /etc/modprobe.d/alsa-base.conf and added the model number, but they have not worked.

I have tried:

ref Reference board, base config
m2-2 Some Gateway MX series laptops
m6 Some Gateway NX series laptops
pa6 Gateway NX860 series

share|improve this question
up vote 2 down vote accepted

The HDA Intel soundchips offer a lot of configuration options, so it might be that you already have everything installed correctly but not configured right.

You probably need to set the correct model when you load the kernel module. This can be done by editing the file /etc/modprobe.d/alsa.conf. Look for an options line for snd-hda-intel and add/change the model parameter. If it doesn't exist, just create a new entry at the end of the file.

options snd-hda-intel model=gateway-m4

Setting model=gateway-m4 is just my first guess, you might have to change it to match your chip. The known model parameters can be found in the kernel documentation in the file Documentation/sound/alsa/HD-Audio-Models.txt (also available on the web).


To help narrow down your chip model you can use alsa-info. Look at the "Codec" entry in the "HDA-Intel Codec Information" section of the output file. Then all you can do is try all models given in that section in HD-Audio-Models.txt.

share|improve this answer
hrmm ... gateway-m4 didn't work, and neither did m1-2. Is there anyway to find out which one to use besides guessing? – Sakamoto Kazuma Mar 21 '10 at 17:45
@Sakamoto See updated answer. – Benjamin Bannier Mar 21 '10 at 18:23
alsa-info isn't recognized as a command. :( is my alsa broken? – Sakamoto Kazuma Mar 21 '10 at 18:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .