Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can the unknown publisher security warning be disabled when running an application in Windows XP Home? It's pretty annoying to have to click run every time...

I have tried:

Run gpedit.msc, and go to Local Computer Policy->User Configuration->Administrative Templates->Windows Components->Attachment Manager and enable "Default risk level for file attachments", and then enable "Inclusion list for low risk file types" and add to this list the file extensions that you want to open without triggering this crap.

But this file, 'gpedit.msc', does not exist on my computer. I checked the system32 folder as well. I don't know, maybe it's for Windows XP Pro.

share|improve this question
You start->run->gpedit.msc If that does not work it is because you have XP Home. – MrStatic Mar 21 '10 at 16:54

I must first warn you that what you want to do is a serious security risk and that fiddling with the registry is not something you normally would want to do anyways, but since you don't have the Group Policies Editor on XP Home, you can try this:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Download]

Open Notepad, copy all of the above in a new file, and save it as filetyperisk.reg file. The name doesn't really matter, but the extension does, so make sure that in the Save as type: field you have selected All Files. Click on save, run the file and on the dialog window that appears, click on Yes.

Also, I strongly suggest you edit that last line, to reflect which file types you want to add to the exception list.

Hope this helps.

share|improve this answer

I notice you mention having to do it every time you run an application, suggesting that it's something specific you've downloaded, and this doesn't need to be done for all future downloads.

If that's the case, find the executable. Right-click on it and select properties. Then click unblock.

share|improve this answer
There is no apparent "unblock" button or similar link in XP SP3. – Jesse Glick Apr 20 '12 at 20:07

If you want to remove the warning for a particular executable file, you can trick Windows into thinking that the file originated from a safe location. You can't accomplish this by a simple copy (in Windows 7 or later, at least), but I most frequently bypass the warning by archiving the file (e.g. in a ZIP file) and then extracting it to a new location, or to the same location after deleting the original file.

share|improve this answer
Of course, I recommend you use extreme caution with this and suspicious files. – palswim Sep 23 '15 at 20:47

You must log in to answer this question.