Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows XP there is a registry setting called ScreenSaverGracePeriod which lets you set a time period between the activation of the screensaver and locking of the screen. As as result, as soon as you see the screensaver being activated, you have X seconds to press a key or move the mouse in order to avoid having to log in again.

Unfortunately, this setting isn't working on my machine. I tried everything I could find on the net (setting the period as string or number), but it still does not work.

Could it be that some kind of security suite (Symantec) or anything else is blocking this feature?

PS: my problem isn't that the time period is wrong, but that there isn't a noticeable time period between the screensaver and locking the screen at all; it's not possible to avoid the locking of the screen.

Cheers, Ralf

Thanx for all your answers and help!

There wasn't enough time to solve the problem with your input (communication with our admins sin't too fast) within the period of the bounty. So I had to select one of your answers to be the final one. I've selcted Hugh's answer because I think he's spent most effort to help me.

I'll keep you updated!

Ralf

share|improve this question
1  
What time period have you specified? –  ChrisF Mar 22 '10 at 9:35
    
something about 5 seconds –  Ralf Mar 22 '10 at 11:19

4 Answers 4

up vote 1 down vote accepted
+100

It sounds like you are a limited user not an administrator, in which case you won't be able to do anything about it anyway - certainly not write to the registry key you are talking about.

In case you are an administrator, does the top of your process tree look like this in Process Explorer?

alt text

I'm specifically interested in whether you have the standard Microsoft winlogon.exe. If so, do you perhaps have a custom GINA?

Finally, to make testing easier, here is a tiny program I wrote (660 bytes) which activates the screen saver as if the computer has been idle (as opposed to just running it as a normal program like the Display control panel does when you Preview a screen saver - which will not lock the screen). Admin privilege not required.

share|improve this answer

Try doing it using Microsoft PowerToys for Windows XP :

Open the program, browse to Logon -> Screen Saver, and then adjust the Grace Period (seconds).

If PowerToys can't do it, then something is seriously wrong with your computer.

share|improve this answer
    
good point. Can't run power toys myself, but will ask our admins for help... –  Ralf Mar 26 '10 at 13:06
    
hm. which of the PowerToys is it? –  Ralf Mar 26 '10 at 13:10
1  
@Ralf - I'd assume TweakUI –  ChrisF Mar 26 '10 at 13:24

The value needs to be a decimal

Click Decimal under the Base heading, and then enter a number in the Value data box that represents the password activation delay in seconds.

Source

If the value is set up correctly I can only suggest you run some experiments.

Setting it to something like 31 seconds and then when the screen saver kicks in wait 5 seconds and see if you can get in without being prompted for the password. Assuming that you can, keep doing this at 5 second intervals until it prompts you for the password.

I'm guessing that at around 25 seconds it'll prompt you for the password. I think that there's an "overhead" on this process that means that there is effectively a minimum value below which, no matter how quick you are, you don't have a grace period.

share|improve this answer
    
I guess that's not the problem. Even when it would be set as hex, there should be a delay betweeen activation the screen saver and locking the screen, but there isn't. –  Ralf Mar 22 '10 at 11:21

is this workstation a member of a domain? If so gpo's may be controlling the graceperiod.

share|improve this answer
    
that was something I was looking for... something which may override the registry entry... but what's a gpo? –  Ralf Apr 1 '10 at 21:11
    
is this workstation in a corprate environment? if so its mostly likely being controlled via gpo's and once again most likely you won't have the ability to make changes.. and if your in a high sec area then forget about requesting a change! –  tonyr roth Apr 1 '10 at 21:19
    
@Ralf: GPO is Group Policy (/Object), but there doesn't seem to be a policy to set the screen saver grace period. Have you tried Process Explorer as I asked? –  Hugh Allen Apr 1 '10 at 23:55
    
no there is no gpo entry you have to do a reg hack applied via a gpo –  tonyr roth Apr 2 '10 at 14:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.