Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every now and then, the trackpad on my MacBook Pro will seem to set its own tracking speed to slow.

I’ll notice that the cursor is moving slowly, and when I check in System Preferences, the tracking speed is indeed at slow, even though I never set it to slow myself.

This might happen before/after switching into a VMWare virtual machine, but I’m not sure. It doesn’t seem to happen on startup or anything, just randomly during use.

I’m running Snow Leopard.

Anyone else seen this?

share|improve this question
1  
Nope, never seen it. It's interesting though. –  Josh K Mar 22 '10 at 15:22
    
What are you running on the VM? I'd guess it's not that, tho. Seems like a warranty-able issue, specially if you can easily reproduce it. –  Cawas Mar 30 '10 at 18:53
    
Just Internet Explorer mainly, I use my VMs mostly for testing websites in different IE versions. I do have Photoshop installed on one of them, and a couple of apps on another (an icon editor and Paint.net), but that’s it. –  Paul D. Waite Mar 31 '10 at 10:24
add comment

4 Answers

I've seen this too. The VM running at the time is Linux (CentOS 5) so it isn't even limited to Windows in the VM (though another login was running Windows, so perhaps, but that shouldn't affect my settings). What will happen first is that the mouse seems to stop moving altogether (either while in an OSX desktop or in VMWare) and any attempt to change focus (alt-tab, or switch desktop) the mouse speed resets to slow.

This is on a Mac Pro running OSX 10.6.3. The Linux VM has the tools installed. The mouse tracking speed gets set to the second slowest.

share|improve this answer
    
Huh — I haven’t personally seen the mouse stop moving altogether, but I might not have noticed it (I’m on a laptop, so I use the trackpad as little as possible). –  Paul D. Waite Jun 14 '10 at 10:23
add comment

This does sound like a problem happening when you switch between the host and virtual machines. I've seen similar problems with keys being stuck down inside a virtual machine and not being able to turn them off, even though they clearly can. Have you got the VMware tools installed? If not that can be a possible solution due to changing from host to VM and back

share|improve this answer
    
Yeah, I got VMWare tools going. I reckon it’s one of those funny VM things too. –  Paul D. Waite Apr 3 '10 at 22:53
add comment

Do you have installed some third-party trackpad or mouse driver? Settings can sometimes change as the default or third-party driver gets loaded when you plug or unplug the mouse. (In you case switching to/from your VM may trigger that problem)

You may want to try USBOverdrive as it can offer finer controls over your mouse(s) and trackpad.

share|improve this answer
    
Nope, no third-party drivers. –  Paul D. Waite Mar 31 '10 at 10:22
    
Aw! Didn’t deserve a downvote though! –  Paul D. Waite Apr 1 '10 at 2:14
    
@Paul D. Waite: I had the Logitech preference pane in mind. As I had a similar issue with it. Mouse speed and settings were changing every now and then. Firing up the preference pane switched correct settings back. (Yup didn't get why i got a downvote... ;-) –  Arko Apr 1 '10 at 8:40
    
Ah gotcha. Yeah, it’s all just native stuff on my machine. –  Paul D. Waite Apr 2 '10 at 20:28
add comment

Open the Windows Registry Editor (Click Start > Run... > type regedit and click OK or press Enter) and navigate to "HKEY_CURRENT_USER\Control Panel\Mouse" and look at the value of "MouseSensitivity" and it will be between 1 and 20. 1 being slow and 20 fast.

Some people have complained that this setting is cleared on reboot, assuming you have the same problem, you can try reading the post below but I would recommend trying that setting first.

http://communities.vmware.com/message/953490#953490

share|improve this answer
    
Hmmm, MouseSensitivity is set to 20 in Windows (which corresponds to its setting in Windows Control Panel). I shall be sure to check that when the slowing down happens again. –  Paul D. Waite Apr 3 '10 at 22:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.