Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 7 as Host, Ubuntu Karmic as guest OS with guest tools installed and I get an annoying glitch when switching from host to the guest machine: Vertical scrolling switches to horizontal! (using the mouse wheel). Since I don't really care about horizontal scrolling, how can I disable this?

I have checked the web and the only thing I found was to play in the xorg.conf file and adding in the section "InputDevice"

Option "ZAxisMapping" "4 5" 

which would enable vertical scrolling only. The thing is, I don't have that section in my config file so I guessed that I would need to add

Section "InputDevice"
    Identifier "VBoxMouse"
    Driver "vboxmouse"
    Option "ZAxisMapping" "4 5"
EndSection

But that does not seem to work after restarting xserver.

Any workaround for this?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I have found a little workaround that I posted on stackoverflow's duplicate question there. A virtualbox [bug][2] is basically behind all this. Quoting from my own answer from stackoverflow if you don't want to go on the website:

Well since the the ZAxisMapping should already disable the horizontal scrolling in my question, but of course did still not seem to work, I have found that it was actually a virtualbox bug that has something to do with the ALT key modifier. Basically the scrolling will switch from vertical to horizontal if the ALT key is pressed at the same time as falling into the virtualbox window. This happened to me because I was using dexpot in Win7 with the desktop switching feature using the alt key.

Until the bug is corrected, the workaround is after getting into the vbox window and noticing that scrolling was switched to horizontal, you need to hit the host key, hit ALT again, then manually click the vbox window to return to it, without touching the alt button. For now, I do not use the alt key for switching desktops, and everything works fine again.

share|improve this answer
    
Cool I get to vote you up on two stack sites!! –  Rupert Madden-Abbott Jan 10 '11 at 4:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.