Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My desktop computer has been upgraded to Windows 7 and ever since whenever I start it up, it resets the date and time to 2007. I tried changing the battery on the motherboard thinking that it would solve, but its still the same.

I didn't face this trouble when Windows XP was installed on this computer. Any ideas how to fix this?

share|improve this question
Did you boot into the BIOS and see if it is reporting the same date and time? – Chris Dwyer Mar 22 '10 at 20:25
Yes the BIOS reports the same time – rzlines Mar 22 '10 at 20:56
I'm assuming by "same time" we mean the time that Windows is displaying (the 2007 one). This would suggest that it isn't Windows' fault. But, since you said you replaced the BIOS battery, I'm at a loss. Do any changes you make to the BIOS stick around after a shutdown? – Chris Dwyer Mar 22 '10 at 21:12
Yes they do, this is one insane problem.. – rzlines Mar 25 '10 at 21:12
up vote 3 down vote accepted

You could tell your computer to sync to an internet time server. It's in the clock options, under a tab called "Internet Time", I believe. I'd give more details (even a screenshot, probably) if I weren't stuck right now in a fresh install of Linux. :)

share|improve this answer
but what happens if I go offline ? My ISP is quite irritating sometimes and I need repeated efforts in order to sign into my account. – rzlines Mar 22 '10 at 20:55
Internet time synchronization does not require a constant connection. The service will attempt to synchronize at start-up and periodically thereafter. If you observe that after syncing your clock, it still falls back to 2007 while your computer is running, there is probably a nefarious program somewhere on your system. Anyway, methinks it's at least worth a shot. – Stephen Mar 23 '10 at 14:34
my system was already synced and it does sometime keep to the actually time, then some days it acts all loney and decides to go back to 2007, freaky little thing – rzlines Mar 23 '10 at 17:59

just change the BIOS battery, it will work fine. it worked for me me.

share|improve this answer
"I tried changing the battery on the motherboard" - He did – Joe Taylor Jun 22 at 9:06
Please read the question again carefully. Your answer does not answer the original question. – DavidPostill Jun 22 at 9:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .