Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have bunch of flash videos and am adding my brand to all of them. The problem is quality gets worse. I am doing with this command: ffmpeg -i /input.flv -vhook "/usr/loca/vhook/drawtext.so -f /usr/share/fonts/somefont.ttf -x 5 -y 5 t MyBrand" -f flv -s 320x240 - | flvtools2 -U stdin /output.flv

Please tell me what I am doing wrong. I need the same quality.

share|improve this question
    
Re-encoding video and adding extra details. What do you expect? –  spender Mar 23 '10 at 1:22

3 Answers 3

If it's a Flash video, why not add an overlay, keeping the original video intact?

share|improve this answer
    
this only works if the OP has acces to the original player. –  Moshe Mar 23 '10 at 1:47

If you want to keep the same quality, don't re-encode with a lossy compression codec. Or, conversely, if you must re-encode with a lossy codec, expect to lose quality.

share|improve this answer

This kind of problem is inevitable with transcoding, but can be ameliorated. Try different bit rates with the -b flag. The default is 200 kb/s, try doubling that to 400 kb/s (-b 400000) and see if you like that result any better. If you pump up the bit rate high enough you should eventually get an OK result (though the file will be large).

share|improve this answer
    
also, you shouldn't need to use flvtools2 for this, -o /output.flv will get ffmpeg to output the right thing (this also means you would not need the '-f flv' clause either). –  Justin Smith Mar 23 '10 at 16:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.