Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install the package skype-ubuntu-intrepid_2.1.0.91-1.i386.deb on Ubuntu 8.04. But in the Package installer, I get:

Error Dependency is not satisfiable: libascound2

And I have tried:

$ sudo apt-get install libasound2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libasound2 is already the newest version.
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.24-24-generic libdns35 linux-headers-2.6.24-24
Use 'apt-get autoremove' to remove them.

I appreciate if anyone can help me with it.

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Are you sure you have the right package to install? Intrepid is Ubuntu 8.10; Ubuntu 8.04 is Hardy. The package may not install properly on your system.

  • The Skype Linux Download page also offers a version for Debian Lenny and a static binary; one of these might install cleanly on your system. I wouldn't bother trying the Fedora or OpenSUSE versions. This post gives instructions for installing the static binary on Ubuntu 8.04.

  • If your post is accurately recording the error, the package appears to have a broken dependency (libascound2 should probably be libasound2). You might be able to fix the package manually with this procedure -- it involves extracting the .deb package contents, correcting the broken dependency, and rebuilding a corrected package.

  • A final option would be to try forcing the installation anyways. Make sure you have the required libraries installed, and use one of these to force the installation:

    • dpkg --ignore-depends=libascound2 -i package.deb
    • dpkg --force-depends -i package.deb

The current libraries required by the Skype package are:

  • Qt 4.4.0
  • D-Bus 1.0.0
  • libasound2 1.0.18
  • PulseAudio 0.9.16 (optional)
  • BlueZ 4.0.0 (optional)
share|improve this answer
add comment

I think it should be noted that it seems the required dependencies are no longer available for Hardy Heron (8.04). Rather, they exist, but the updated versions requested do not work with Hardy. I found that an older version of Skype will work just fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.