Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have launched an instance of EC2. Initially the security group I created did not have the port 80 open. I sshed and installed Apache etc, and now want to open port 80. I am using elasticfox.

So I

  1. go to Security Group - > [My Group name] - > Grant new permission
  2. Open up the port 80(Http with TCP) for network range 0.0.0.0/0

Now my assumption is that these ports should be opened up on the instance, but the instance is not responding on the allocated IPs, public DNS entry. What should I do next?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

If you're using a windows instance, then you also need to open the port on that instance's individual firewall.

share|improve this answer

You're probably using a RedHat instance, which has port 80 blocked in the firewall config by default.

run the following command and enable www/http/80 in the firewall config: system-config-firewall-tui

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.