Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have shortcuts to C:, D:, and E: in my quick launch bar. C and E work fine when I click on them, but D does nothing (that I can see) when I click on it. D and E are both SUBST'd drives pointing to folders that happen to be network shares. (I do this rather than mapping them so it doesn't have to go through the network layer--that way it works faster and I still get recycle bin functionality, etc.)

If I go Start->Run and type D: or D:\, I get an error box saying:

This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel.

If I go to My Computer and double-click the D drive, it comes up fine. Also, if I type \\servername\sharename pointing to the same place, it comes up fine.

This just started happening this morning, out of the blue. It has been working fine ever since I set it up. Why might this be?

share|improve this question

closed as off-topic by Ƭᴇcʜιᴇ007, gronostaj, teylyn, soandos, tombull89 Jul 5 '13 at 9:10

  • This question does not appear to be about computer software or computer hardware within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

4  
This question appears to be off-topic because it is too localized to be useful to future visitors (a reboot fixed it). –  Ƭᴇcʜιᴇ007 Jul 2 '13 at 18:25
    
Also, you aren't bypassing the network layer, and this offers no improvement in performance. –  soandos Jul 5 '13 at 0:31
add comment

3 Answers 3

You may consider mapping a drive instead of using SUBST. Mapping a drive will survive reboots cleanly, and I've not seen any of the behavior you're describing.

To map a drive, choose Tools -> Map Network Drive in Windows explorer. The drive you'll be mapping is:

\\[your-computer-name]\[drive-letter]$\[path]\[to]\[folder]

EG, if your computer was called MYCOMP, and you wanted to map to C:\Program Files, the path you'd enter at the first step of the Map Network Drive wizard would be:

\\MYCOMP\c$\Program Files

That should resolve your issues. Note that will need to remove your SUBST mapping prior to doing this.

share|improve this answer
    
Mapped drives do not have recycle bin functionality, unfortunately. Note that I too have never seen this behaviour before. Thanks, though. –  Kev Mar 24 '10 at 12:24
add comment
up vote 0 down vote accepted

Classic Windows solution: reboot.

share|improve this answer
add comment

You should be mapping drives to network shares. SUBST is used to map a drive to a local folder.

share|improve this answer
    
It is a local folder on that computer--D: maps to C:\something. It just happens to be a network share as well. I only included that piece of information because it was one of the ways that I could actually access it while this glitch was happening... –  Kev Mar 24 '10 at 15:19
    
My bad. One thing I have noticed in the past, is that a SUBST drive shows as 'Disconnected' after a reboot until you go browse it in explorer. That may be why it is not available on the run command. Maybe try writing a DOS batch file that sits on C that will start your command and change the drive to D... –  baldy Mar 25 '10 at 8:27
    
I have the SUBST in my logon.cmd script, so it always connects properly from the start. After a reboot, it's working correctly from the run command again. I haven't been experiencing this problem since the reboot. Thanks, though. –  Kev Mar 25 '10 at 14:55
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.