Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an MSI-RC410 motherboard with onboard ATI Radeon XPress 200 series Graphics card.

I have used OpenSuse-11.0 on my PC for over an year. but when I tried to upgrade to OpenSuse-11.1, I managed to install it only to find that several features were missing. for example /dev/cdrom was missing.

Also install DVD of Fedora 11 did not work.

I have also tried Ubuntu-9.10 live cd. When I boot from the CD i get the initramfs command prompt. Still able to install old versions of these OSs.

What is the reason for this behavior?

Does it have to do anything with the new version of the linux kernel not being compatible with my hardware?

What should i do to install new versions of Linux?

share|improve this question
add comment

migrated from serverfault.com Mar 24 '10 at 8:21

This question came from our site for professional system and network administrators.

1 Answer

My guess is it's related to some FAKERaid integrated in the motherboard.
Disable it from BIOS if such device exists and try again. (or maybe try a BIOS upgrade)
More details from the error would be useful (the ubuntu case).

This is what I meant by FAKERaid:

Operating system-based RAID doesn't always protect the boot process and is generally impractical on desktop versions of Windows (as described above). Hardware RAID controllers are expensive and proprietary. To fill this gap, cheap "RAID controllers" were introduced that do not contain a RAID controller chip, but simply a standard disk controller chip with special firmware and drivers. During early stage bootup the RAID is implemented by the firmware; when a protected-mode operating system kernel such as Linux or a modern version of Microsoft Windows is loaded the drivers take over.

These controllers are described by their manufacturers as RAID controllers, and it is rarely made clear to purchasers that the burden of RAID processing is borne by the host computer's central processing unit, not the RAID controller itself, thus introducing the aforementioned CPU overhead from which hardware controllers don't suffer. Firmware controllers often can only use certain types of hard drives in their RAID arrays (e.g. SATA for Intel Matrix RAID, as there is neither SCSI nor PATA support in modern Intel ICH southbridges; however, motherboard makers implement RAID controllers outside of the southbridge on some motherboards). Before their introduction, a "RAID controller" implied that the controller did the processing, and the new type has become known by some as "fake RAID" even though the RAID itself is implemented correctly. Adaptec calls them "HostRAID".

A BIOS upgrade is just simple procedure recommended by your hardware manufacturer if you are not already using the latest version.

I don't think the error you showed me can be the reason why Ubuntu fails to boot.

share|improve this answer
    
I am still able to install the old versions of Linux. –  Rohit Banga Mar 23 '10 at 14:06
    
running vista right now –  Rohit Banga Mar 23 '10 at 14:07
    
FAKERaid I didn't understand. BIOS upgrade do you really think it would help. need more advice before trying this option. –  Rohit Banga Mar 23 '10 at 14:08
    
Ubuntu- I chose the option try ubuntu without affecting my computer. then after some gui loading I suddenly got initramfs command prompt. When i ran dmesg from this prompt, some 20 lines from the end i saw the message radeon kernel modesetting DISABLED. Not sure if this has something to do with the crash. I also have Netgear WG311 wireless adapter but that worked with old version of ubuntu –  Rohit Banga Mar 23 '10 at 14:11
    
can i run some command from initramfs command prompt to learn more about the cause of the error. –  Rohit Banga Mar 23 '10 at 15:35
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.