Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install Mplayer or VLC player on ubuntu feisty but i can't do it. I try with apt-get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  mplayer: Depends: libasound2 (> 1.0.16) but 1.0.13-1ubuntu5 is to be installed
           Depends: libavcodec51 (>= 0.svn20080206-8) but it is not going to be installed or
                    libavcodec-unstripped-51 (>= 0.svn20080206-8) but it is not installable
           Depends: libavformat52 (>= 0.svn20080206-8) but it is not going to be installed or
                    libavformat-unstripped-52 (>= 0.svn20080206-8) but it is not installable
           Depends: libavutil49 (>= 0.svn20080206-8) but it is not going to be installed or
                    libavutil-unstripped-49 (>= 0.svn20080206-8) but it is not installable
           Depends: libcaca0 (>= 0.99.beta14-1) but 0.99.beta11.debian-2build1 is to be installed
           Depends: libcdparanoia0 (>= 3.10.2+debian) but 3.10+debian~pre0-4build1 is to be installed
           Depends: libcucul0 (>= 0.99.beta14-1) but 0.99.beta11.debian-2build1 is to be installed
           Depends: libfaad0 (>= 2.6.1) but it is not going to be installed
           Depends: libfribidi0 (>= 0.10.9) but 0.10.7-4build1 is to be installed
           Depends: libgif4 (>= 4.1.6) but it is not going to be installed
           Depends: libjack0 (>= 0.109.2) but it is not going to be installed
           Depends: liblzo2-2 but it is not going to be installed
           Depends: libopenal1 but it is not going to be installed
           Depends: libpostproc51 (>= 0.svn20080206-8) but it is not going to be installed or
                    libpostproc-unstripped-51 (>= 0.svn20080206-8) but it is not installable
           Depends: libspeex1 (>= 1.2~beta3-1) but 1.1.12-3 is to be installed
           Depends: libsvga1
           Depends: libswscale0 (>= 0.svn20080206-8) but it is not going to be installed or
                    libswscale-unstripped-0 (>= 0.svn20080206-8) but it is not installable
           Depends: mplayer-skin
  python-apt: Depends: libapt-inst-libc6.7-6-1.1
              Depends: libapt-pkg-libc6.7-6-4.6
  scim-gtk2-immodule: Depends: libscim8c2a (>= 1.4.6) but 1.4.4-7ubuntu1 is to be installed
  scim-modules-socket: Depends: libscim8c2a (>= 1.4.6) but 1.4.4-7ubuntu1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I try apt-get -f install but it doesn't work neither. What to do please help me ?!

share|improve this question
2  
I think you should provide your /etc/apt/source.list –  slubman Mar 24 '10 at 13:20
    
could you try sudo apt-get update ? –  Ye Lin Aung Mar 24 '10 at 13:48
add comment

2 Answers 2

It looks to me like you might have an invalid /etc/apt/sources.list file. Try:

sudo apt-get update

Then, try installing VLC again.

share|improve this answer
add comment

If this didn't help and you still getting an error:

The following packages have unmet dependencies. mplayer: Depends: mplayer-nogui but it is not going to be installed Depends: libvdpau1 but it is not installable E: Broken packages

Try to install these packages:

$ sudo apt-get install mplayer-nogui

The following packages have unmet dependencies. mplayer-nogui: Depends: libvdpau1 but it is not installable E: Broken packages

And again:

$ sudo apt-get install libvdpau1

Package libvdpau1 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package libvdpau1 has no installation candidate $

Ah-ha, gotcha! The issue is fixed by adding:

deb http://ppa.launchpad.net/team-xbmc-svn/ppa/ubuntu $your_distro main
deb-src http://ppa.launchpad.net/team-xbmc-svn/ppa/ubuntu $your_distro main

to the /etc/apt/source.list and running:

sudo apt-get update
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.