Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a pretty straightforward setup where I'm storing media files on an XP pro machine, and sharing the folder to be accessed by other XP pro machines around the house. (Typically, there's only one client accessing the share at a time, although there may be several with the share mounted.) It's been working just fine for years, but I've recently started having some problems.

A couple of days ago, the host PC had power disconnected while it was running. It was restarted and everything seemed fine initially, but since then browsing the shared folder from client machines has been extremely slow and actually reading data is all but impossible. The problem exists in every access method I've tried: Windows Explorer, VLC dialogs, command line, etc.

My first thought was that the disk was experiencing problems, but there are no problems viewing the files locally on the host machine.

My second thought was that there was a network problem on the host machine, so I removed and reinstalled drivers for the NIC with no change.

My third thought was that there might've been a problem elsewhere on the network, so I swapped out hardware to no avail.

I'm regrouping and trying to come up with a methodical approach to figuring out what might be wrong. I would of course be thrilled if you can suggest specific problems (Microsoft KB articles, etc.) that I might check, but I'm not expecting a silver bullet. If you can help me outline an approach to identify the problem (including recommended tools, e.g., disk checkers, network analyzers, etc.) I'd greatly appreciate it.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Wireshark is a useful tool for examining network traffic to see if your network has lots of errors and retransmissions. I don't think this is the problem, though.

My instinct says that perhaps your PC damaged a sector or two during the power drop, reading the sector is now iffy, and that sector contains something important for serving files over the network. I'd suggest running chkdsk. If that doesn't work, visit your drive vendor's website for disk checking tools or try Spinrite. Spinrite is $pendy, but I've found it quite useful in the past.

share|improve this answer
    
Well, it seems like it's a network problem. Chkdsk reported no errors, but when I happened to try connecting to the machine with remote desktop, it timed out. Wireshark reported lots of retransmissions. I'll have to work on that. Thanks for the suggestions. –  Ickster Mar 27 '10 at 2:43
    
Well, Wireshark gave me the answer. The NIC was bad. Replaced it and everything's back to normal. Thanks for the suggestion. –  Ickster Mar 27 '10 at 21:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.