Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 x64 guest that acts very strange - the VM is very slow and taskmgr will consume 50% (with 2 cores) or up to 99% (single) of the CPU when everything else is idle.

  • Host is Windows 7 x64 with VMware Workstation 7.0.1
  • VMware tools are installed
  • the same VM, when running on another PC with VMware Server 2.0 will work OK (CPU at ~0% when idle)

I've tried (with no effects)

  • enabled/disabled 3d
  • selected 1 or 2 cores
  • adjusted memory (1gb/500mb)
  • adjusted the bios
  • mem.hotadd = "FALSE"
  • disabled page trimming

Windows 7 x86 guests on the same machine do not have this problem.


Edit: I usually run multiple VMs on that system.

Now I noticed that

  • if I start the x64 VM first it will run OK.
  • but when I start another VM (x86) with multiple processors it will have CPU issues.
  • if I suspend the first VM the issues in the second VM will disappear.

Apparently I can only run one VM with multiple processors without issues.

share|improve this question
1  
What CPU does the host have? –  kmarsh Mar 25 '10 at 13:09
    
It has a Intel Core2 Duo T9300 (2.5GHz). VMware let's me select 2 processors and 2 cores. –  hcris Mar 25 '10 at 13:27

3 Answers 3

up vote 2 down vote accepted

Updating to Workstation 7.1 resolved the issue.

share|improve this answer
    
Thank you for informing us of the solution to the problem. However, best practice is for the poster to update only his post, leaving the answers area to others. –  harrymc Jun 9 '10 at 9:15
3  
@harrymc - you must be new here. From the FAQ: "It's also perfectly fine to ask and answer your own question" –  ta.speot.is Jun 9 '10 at 10:23

My only thought is to check to make sure VT-x is enabled in bios and being utilized by vmware workstation though I am thinking the x64 images won't boot without it.....worth double checking though.

share|improve this answer
    
Yes, VMM is enabled. –  hcris Mar 25 '10 at 12:22

Did you try removing Aero from the host? That caused me a headache sometime ago (and the guest also).

Other thing: Select only 1 CPU since you have only one. Add 2 cores if you want, since you've got two. It's simply because you give out too much CPUs. Try only giving out 1 or 2 cores. (Or play with this setup).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.