Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install the Shrew VPN client. In the process of installation an error occurs:

Error 0x800f0203: Couldn't install the network component.

It occurs when the installer tries to execute

C:\Program Files\ShrewSoft\VPN Client\netcfg.exe -add service vflt C:\Program Files\ShrewSoft\VPN Client\drivers\vfilter.inf

Antivirus, firewall, etc are disabled and I'm running as an administrator.

I've installed vfilter.inf manually, but it leads nowhere.

I have a similar situation with the Cisco VPN client. I need a VPN client supports group authorization, and imports the settings from pcf format.


Windows Vista 32-bit, Shrew client 2.1.5, also try 2.0.0 for 32-bit.

share|improve this question

migrated from stackoverflow.com Mar 25 '10 at 20:46

This question came from our site for professional and enthusiast programmers.

It may be as a result of a corrupt file called infcache.1 in the %windir%\Inf directory. As the name implies, infcache.1 is a file that caches driver inf files. Find that file and rename it to infcache.1.bak

You should be able to install the Shrew VPN client after that. I would recommend first uninstalling all VPN clients that you've already tried to install and then rebooting. Rename the infcache.1 file first thing after a reboot. You may have to reboot again before trying the installation.

share|improve this answer
    
This worked for me. Thanks! – Xhantar Apr 26 '12 at 10:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.