Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am unable to consistently get screen sharing in iChat to work. When I select an online buddy, under the Buddies menu the options "Share my screen with Bob" and "Ask to Share Bob's Screen" are disabled. Sometimes starting a chat with that person will enable the screen sharing but often not. Once its enabled it works fine but I have no idea what the key is to getting it enabled. It seems fairly random when it works. This is over the public internet using Google Talk. Both ends are running OSX 10.5.

share|improve this question

4 Answers 4

Are you both running iChat? I've seen third-party chat apps have limited/buggy iChat interoperability for A/V chats. I wasn't aware of anyone else advertising screen sharing, but it's within the realm of possibility.

iChat does some tests to make sure your machine's CPU and Internet connection are good enough for the kind of A/V chat you're trying to do. Is it possible that screen sharing is not enabled for people on poor Internet connections, or behind restrictive firewalls, or behind crappy NAT gateways that don't support/allow NAT-PMP or UPnP?

share|improve this answer
    
Yup, both sides are running iChat. Its possible something at the isp level is blocking it but it does work sometimes so its more likely related to a poor internet connection (if it is any of these issues). Is there a way to tell? Thanks. –  Joel Mar 26 '10 at 4:49
    
Well, there's "Connection Doctor" on the "Video" menu, which can tell you a few things. Might at least get you started. –  Spiff Mar 26 '10 at 6:04

If they are running an older version of iChat screen sharing is not possible. For example, my iMac has Snow Leopard, my wifes aging iBook has Tiger. Screen sharing is not possible between these two machines via iChat.

share|improve this answer
    
Thanks but both ends are running Leopard (i.e. 10.5) and it works sometimes so its definitely posible. –  Joel Mar 26 '10 at 4:48

Sometimes(!) iChat will start but won't log in if SysPrefs | Internet Sharing is enabled. ("Sometimes", because I just tested this with an AIM account between a Macbook (10.6.3) and an iMac (10.6.4) and at first the iMac wouldn't log in if Internet sharing was enabled; now, after several iterations of testing, it will. The Macbook would log in either way. ???) I've seen this since at least 10.5.something.

If you've got Internet Sharing enabled on either end, try disabling all sharing and if you notice any improvement, add them back one at a time to find the culprit. Curiously, iChat seems not to care about the SysPrefs screen sharing setting; only it's own settings.

share|improve this answer
    
I just noticed this question is from March '10, but recently bumped. OP is probably gone. I'll leave my answer here anyway; maybe it will help someone another day. –  JRobert Jun 24 '10 at 0:09

Make sure that you are signed out of other GTalk sessions. In particular, make sure that you have closed any open Gmail web pages as these will sign you in automatically to GTalk. iChat will only enable screen sharing if it knows it is talking to another iChat client.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.