Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

One of the "features" of VMWare Fusion is that it associates files on the Mac host with programs in the VM. Unfortunately I uninstalled VMWare Fusion, and my Mac still has applications in VMWare Fusion associated with it. How can I remove the associations? I went to the Genius Bar, but they didn't know how to fix it (they cleared my cache, but that didn't do it.)

I am running OSX Snow Leopard

share|improve this question
up vote 1 down vote accepted

You can try rebuilding your Launch Services Cache by running the following command in the Terminal:

sudo /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

The Launch Services Database is in charge of file/application associations.

Also, how did you uninstall VMWare Fusion - using the Uninstaller or just throwing away the application?

To use the Uninstaller (if you've just thrown away the application) you can run it either from the disk image you used to install VMWare (if you still have it) or open it from /Library/Application Support/VMWare Fusion. Once that is run it will remove all the helper tools VMWare uses to help integrate the virtual machines with the host operating system (in this case Mac OS X).

share|improve this answer
I tried it and it didn't work. Do I need to reboot or something? I looked for the VMWare uninstaller, but couldn't find it. Finally I threw away the application. Is there a common place all the uninstallers can be found, or are they just scattered around? – Jim McKeeth Mar 29 '10 at 1:40
Uninstallers aren't standard so where they are available varies widely if they are installed on your system at all. I've updated my answer with where the Uninstaller is now that I know that is what you need. – Chealion Mar 29 '10 at 15:02

Remove the "Application" folder (in your Virtual Machines dir).

share|improve this answer
My Virtual Machines directory was empty. I removed it anyway. – Jim McKeeth Apr 6 '10 at 4:36

The following fixed it for me:

rm -rf ~/Library/Application\ Support/VMware\ Fusion/

I didn't have to rebuild the associations or anything - all the VMware Fusion entries went away immediately.

share|improve this answer

remove [vmdir]/Applications if you can't even find ~/Library/Application\ Support/VMware\ Fusion

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.