Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Truecrypt 6.3a in Windows 7, but cannot remove file, just read only.

When I create a virtual hard disk in Windows 7 using Truecrypt 6.3a (support Windows 7), but in the virtual hard disk I can't remove or delete, it just can read only, not write it.

share|improve this question
    
Are you trying to remove a file within the Truecrypt archive, or the archive itself? –  JRobert Mar 26 '10 at 18:20
    
What error message are you getting? –  Stephen Jennings May 2 '10 at 15:37

4 Answers 4

In Windows 7, with Truecrypt 6.3a, and Window's user account control enabled (default) the mounted true crypt volume's security permissions default to read-only for the local computer's "users" group.

This assumes that you are NOT mounting the volume "read-only" in truecrypt.

Applications that are not "run as administrator" therefore only have user-level access and require UAC to prompt and you to respond in order to achieve administrator permissions, even if you are a member of the local administrator group. This works when creating a folder or renaming a file on the mounted volume, but when you open a file in an app, e.g., Excel, it sees the file as read-only and never prompts you to elevate permissions.

Temporary work-around is to edit the volumes WINDOWS file permissions after mounting and grant yourself full control OR full control to the USERS group.

Not sure if this can be changed in Truecrypt's mount procedure to automatically grant the logged-in user full control or if there is a better work-around.

share|improve this answer

You have to run Truecrypt as Administrator

Left click on executable and run as administrator

Works for me... and for you ;-)

share|improve this answer

There is a very easy way to fix this:

  1. Go to Start>All Programs>Truecrypt (or wherever you have the shortcut that you usually use to start TrueCrypt) and right click on the shortcut.
  2. Chose properties
  3. Click on the compatibility tab and change the compatibility mode so that you run TrueCrypt in the compatibility mode that matches the operating system you used when creating the encrypted TrueCrypt file (in my case Windows XP service pack 3)
  4. Confirm by clicking "Apply"

If you now mount a TrueCrypt container you should not be limited to read only access anymore.

If the problems persist try to run TrueCrypt as an administrator by right clicking on the TrueCrypt shortcut when starting it and choosing "Run as administrator". Additionally you can also right click on the unmounted TrueCrypt container choose properties, go to the security tab and give additional user rights to your user account. Latest after that it has to work.

I figured this out after hours of searching, I hope this saves whoever reads this some time.

share|improve this answer
  1. When you mount the volume, one of the mount options is "Mount volume as read-only". Are you sure this is unchecked?

  2. Do you have access to write to the folder where the TrueCrypt volume exists? Try creating a file in the same folder, or try renaming the TrueCrypt volume itself (when it's unmounted). If this doesn't work, you need to give yourself permissions to modify the TrueCrypt volume file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.