Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running SysInternal's Desktops 1.02 and FireFox 3.6.2. I have noticed that while I can have Internet Explorer 8 open in multiple virtual desktops, you can not do the same with Firefox. If you try you get the error message:

Firefox is already running, but is not responding. To open a new window, you must close the existing Firefox process, or restart your system.

I did a little digging around to work around this and came up with creating a second profile via the Firefox profile manager (accessed by starting Firefox with the "-p" switch). This unfortunately created a new problem which is my add-ons (of which I use many) do not stay synchronized between profiles.

Is there a better approach here?

share|improve this question

5 Answers 5

With the Sysinternals utility, Firefox on another desktop runs as a different process, just as if you had run it as:

firefox.exe -no-remote

(That usage will also complain if you try to use the same profile twice, even if you're not running Desktops).

It looks like Firefox is using Windows messages to determine whether there's already a Firefox instance running, and doesn't find anything on the same desktop, so starts a new instance.

And this is why you can't use the same profile.

I'm guessing that IE8 works differently (possibly because it uses multiple processes anyway) and uses some communication mechanism that works across multiple desktops.
IE8 probably co-ordinates all access to user (profile) data through a single process; Firefox doesn't, so it will prevent multiple processes using the same profile to avoid the possibility of file corruption.

Alternative

VirtuaWin, available free from Sourceforge, does essentially the same job, and works the way you'd expect with Firefox - multiple Firefox windows across various desktops, all from the same Firefox instance with the same profile.

share|improve this answer
    
The inability to easily start multiple independent browser windows is one of my pet peeves about FF (pretty much my only one). –  Lawrence Dol Mar 27 '10 at 7:43
    
@Software Monkey Yah, it's the first real wall I've hit w/FF. –  Aaron Bush Mar 29 '10 at 3:58
    
@njd I'm going to hold out for a solution, but +1 for all the extra info. –  Aaron Bush Mar 29 '10 at 3:59
  1. Run firefox -ProfileManager to create a new profile, say test (Note that all Firefox windows must be closed before run this command)

  2. Run firefox -P test -no-remote to run another instance of Firefox with the newly created profile

share|improve this answer
    
I believe I mentioned I was already doing this. –  Aaron Bush Mar 29 '10 at 3:56

I haven't tried this, but maybe you could could copy and rename your main profile (as many times as you want), then run extra instances of Firefox using these new-but-identical profiles. (Just remember to save any new bookmarks in your original profile or thing could get confusing.)

share|improve this answer

Simple solution is to open task manager and kill(end) the firefox process. Next time you fire up firefox you will find recovery tab and you can start from there.

share|improve this answer
    
The question was about running concurrent instances, not about to kill instances until you aren't running concurrent instances anymore. –  Aaron Bush Mar 29 '10 at 3:57
1  
I think if you don't have the associated windows with the current firefox process in memory you will get the error that firefox is already running for that profile. So the only option left is to kill. –  Xolve Mar 29 '10 at 6:12

The answer by hvtuananh still works today on Win 7 for me (using MS:Desktops). I added a second profile in ProfileManager (called second_user) and also unchecked the box to always use the selected profile at startup. Then on FF Properties I added the arg "-no-remote". I can get multiple instances of FF now. There's still a problem though - they all open on my first virtual desktop even though I was on my 4th virtual desktop when I clicked my QuickLaunch bar icon for FF. (Yes, I added it back.)

The fix for that is this: I went back to my 4th virtual desktop, launched a command line window, cd'd to the firefox directory (C:\Program Files\Mozilla Firefox)(don't really need to do that when the path to FF is in the system path environment variable), and launched it from there with a command line command (firefox -P second_user). This time the FF window opened on my 4th virtual window. Done. Mischief managed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.