Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My dvd-rom works fine because I can play dvds on it, however when the dvd is a blank one the drive refuses to recognize it. So I can't burn dvds anymore because the drive shows up as empty in my disk burning software (dvd flick).

Any idea what the problem is and how to solve it?

PC: Windows vista home basic, 32 bit

share|improve this question
6  
are you sure it's a dvd burner drive? (read-only drives don't recognize blank discs at all.) could it be a dvd-reader-and-cd-burner? –  quack quixote Mar 26 '10 at 17:45
1  
Use something like speccy or cpuz and see what model the drive is and check as quack said if it supports writing. –  MrStatic Mar 26 '10 at 23:41

4 Answers 4

hey , i had this problem before on my friend's windows xp laptop.. but i am not sure if it would work with vista...

try this:

Control panel > Administrative Tools > Services

search for something like > IMAPI CD-Burning COM Service right click on it > Properties

let Startup type: > Automatic , press start and OK

-- if that doesn't work ..then i guess that you have a messing files..

that mean you have to install it from your vista CD ....

1- put your win Vista CD .

2-write on run sfc /scannow

and i hope that works with vista..

share|improve this answer

This is an old thread, but maybe this can kind of help some people...temporarily.

I am having a similar problem with Vista 64, but it all started when oracle virtual box crashed once. My DVD drive was no longer recognized by windows after that, even though it runs fine if I boot into linux. I fixed the windows not recognizing my DVD drive problem by removing upper and lower limits in the windows registry. However, since that time my drive often fails to recognize both blank media and finalized CDR/DVDR media. If I go run the http://support.microsoft.com/fixit tool for DVD/CD drives, the tool reports no problems and says nothing needs fixed, BUT my drive suddenly starts working after running the tool until the disk is ejected. Again, the DVD drive is working flawlessly with all types of media in linux.

share|improve this answer

I am running Windows 7 x64 and I was also having this problem. Both my disc drives were working perfectly then, for no apparent reason, they both stopped recognizing blank discs. After much tinkering I came across a solution.

I went to Device Manager, right clicked each DVD drive, selected Properties, and finally clicked on the tab for DVD Region. It indicated that a DVD region had not been selected and that I had 5 changes remaining. I selected my region and clicked OK.

My drives are both working again!

share|improve this answer

After reading the advice in the first answer, I came up with a solution that used the same method but I needed to activate different services.

Here's what worked for me:

  1. Control Panel (in Classic View) > Administrative Tools > Services
  2. Search for "Shell Hardware Detection" and "UPnP Device Host"
  3. Right Click on each and choose "Properties"
  4. In the pull down list in the middle of the window, choose "Automatic"
  5. Click "Apply" and close the window.

Remember to do this for each of these services. I'm not sure which one fixed it, as I automated both of their start-ups at the same time, but it worked for me. Hope it works for you too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.