Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a home network set up with a couple of Windows XP computers. I'm now trying to add our new netbook to it - also running XP. (The goal is to share files and a printer.)

I have run the Network Setup Wizard several times, always making sure that the workgroup name is the same as the others, and have rebooted several times, but whenever I try to 'view workgroup computers,' the netbook only sees itself in the group.

I have a Windows XP CD, but the netbook has no drive (and it's Home Edition, while the netbook has Pro). The wizard has some options for floppy disks, but that's useless to me these days.

What is this wizard actually trying to do, and can I do it manually? Is it some kind of IP address configuration? Do they need to share an encryption key? Where else can I check besides the useless wizard?

Surely it can't be this hard.

Update 1

@coneslayer:

  • I can ping any of the three computers from any of the others using their IP addresses. (If anyone found this question through a web search, you can find a computer's IP address from the command prompt by typing ipconfig. From another computer's command prompt, you can type ping 10.0.0.6 (or whatever the IP address was), which for computers means "say hi and see if it says hi back.")
  • The netbook can ping the other two using their names, but pinging the netbook's name produces "Ping request could not find host (computer name). Please check the name and try again." (The names I'm using are what shows in parentheses for each computer under the "view workgroup computers" section in Windows.)
  • I don't know what the "SHARENAME" part of your question means, so I haven't tried that.

All this testing is after I tried these additional steps:

  • Noticed that while the netbook doesn't see any other computers in its workgroup, my office computer sees the netbook listed in its workgroup.
  • Tried clicking on the netbook from my office computer's workgroup menu. Got a message that said "(computer name) is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. The network path was not found."
  • Did some Googling on that and found this article. Ran the "Microsoft Fix It" tool on all three computers and reset all of them.

Still no luck.

share|improve this question
    
Can you ping the other computers using their IP addresses? Can you ping them using their names? Can you get to their shared folders by hitting Win+R for a run dialog, and entering \\COMPUTERNAME\SHARENAME ? –  coneslayer Mar 27 '10 at 2:09
1  
SHARENAME is the name of a shared resource, like the name of a shared folder. In Explorer, right-click on a directory that you want to share, or that you are already sharing. Click "Sharing & Security" and go to the "Sharing" tab. If it's not already checked, check "Share this folder on the network". The share name, which you can change, will be listed below. So if you have a shared directory with a share name "stuff" on a computer named "fred", try going to \\fred\stuff from the netbook. –  coneslayer Mar 27 '10 at 22:23

2 Answers 2

up vote 2 down vote accepted

Often on Windows XP Computers you need to enable the correct network protocol in order to get your box to share files (or even be able to see the network).

Try enabling/installing IPx.

  1. Open Network Connections
  2. Under LAN or High-Speed Internet, click the local area connection for the home or small office network.
  3. Under Network Tasks, click Change settings of this connection.
  4. In Local Area Network Properties, click Install.
  5. In Select Network Component Type, click Protocol, and then click Add.
  6. Click NWLink IPX/SPX/NetBIOS Compatible Transport Protocol, click OK, and then click Close.
  7. In Network Connections, on the Advanced menu, click Advanced Settings.
  8. On the Adapters and Bindings tab, under Connections, click the local area connection on which you are enabling IPX/SPX file and print sharing.
  9. Under Bindings for Local Area Connection, under File and Printer Sharing for Microsoft Networks, clear the Internet Protocol (TCP/IP) check box, and then click OK.

http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/hnw_ipx_fileandprint_sharingw.mspx?mfr=true

share|improve this answer
    
Awesome! This did the trick for me. I did these steps on the netbook, then repeated them on every computer on the network (even though the other two could already see each other) - each time I did it on one of the others, the netbook saw it for the first time under "view workgroup computers." I can now share files and the printer. Thank you! –  Nathan Long Mar 29 '10 at 13:21

Do you have a firewall installed?

If so make sure it's set to let all local traffic through in both directions.

share|improve this answer
    
I have Windows Firewall turned on. I tried turning it completely off on the netbook and my office computer, and nothing changed. –  Nathan Long Mar 27 '10 at 21:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.