Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I play mkv file in VLC, it produces this error

No suitable decoder module:

VLC does not support the audio or video format "undf". Unfortunately there is no way for you to fix this.

What does it mean and how to fix it?

My OS is Windows 7.

Thanks and regards!

share|improve this question

This means that VLC doesn't recognize the format of one of the data streams in your MKV file. It can't play this file and considers it unfixable.

Without more details, we can't tell you why VLC thinks the file is broken. You can try:

  • playing it in another media player;
  • updating to a later (or earlier) version of VLC and trying again;
  • re-encoding the file (if you encoded the MKV yourself), possibly using different settings or a different encoder; or
  • downloading the file again (if you downloaded it from the Internet).

You might look into MKVtoolnix (for Linux, OSX, Cygwin and Windows) or MKVtools (for OSX). MKVtoolnix is a set of tools for creating, altering, and inspecting MKV files; your MKV may be reparable using them. Start with the following command, and inspect the output for errors; it may give you more information about what's wrong with the file:

mkvinfo filename.mkv
share|improve this answer
    
Thanks! It seems that the mkv file contains rmvb format. I can play it in Media Player Classic after installing Real Alternative, but still cannot in VLC. – Tim Mar 27 '10 at 3:24
1  
@quack: Congrats on the Diamond! :) – Josh K Mar 27 '10 at 3:32
    
@Tim: interesting! dunno why anyone would put RMVB into an MKV, but ok. seems that VLC is known to be so-so with Real codecs (videolan.org/vlc/features.html), and that may get better eventually, but probably not very soon. – quack quixote Mar 27 '10 at 3:35
    
@Tim: the more interesting question is why VLC doesn't recognize it; this might be due to VLC's MKV decoder not expecting RMVB data, but i'd suspect the MKV isn't correctly formatted. this is only your fault if you created the MKV, but MKVtoolnix might be able to fix it so that VLC actually recognizes the file correctly (even if it doesn't play it well!) – quack quixote Mar 27 '10 at 3:38

Here are some ways to help you solve no-sound problem with VLC:

  1. Unmute Your VLC Player

    1. Click the speaker icon (it's at the bottom of your task bar near your clock);
    2. Click the "mixer." If your VLC player is running, it will show up in the mixer like below;
    3. Unmute VLC and your sound works again.
  2. Adjust Audio Settings

    If it doesn't work after you unmute VLC, try adjusting audio settings of this player.

    Here is how: go to Tools > Preferences > Audio and make sure Enable audio is ticked. Then go to Output and try a different default.

  3. Convert Video Format

    If it still doesn’t work after trying the solutions above, you may convert the original video to another format, because VLC may have troubles playing some MKV or MP4 media file. To convert MKV files, you can use Handbrake.

  4. Switch to Another Media Player

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .