Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been getting a message on my monitor where "Input not supported" is floating around. This only happens when I manually turn the monitor off and then later turn it back on. Leaving the monitor on and allowing it to go to the screen saver doesn't seem to cause the issue (but I prefer to turn the monitor off if I'm going to be away from the computer for any length of time).

Any ideas what might cause this, only when the monitor is turned off manually?


  • Acer X203w monitor
  • Radeon 9600 Pro Video card
  • Linux Mint 8 (Helena)
  • Resolution 1680 x 1050 (16:10 - Preferred native resolution for the monitor)
  • Refresh Rate 60hz

Here is what is in my xorg.conf file:

Section "Device"
        Identifier      "Radeon 9600"
        Driver          "ati"
        BusID           "PCI:1:0:0"
        Option          "XAANoOffscreenPixmaps"
        Option          "AccelMethod"   "XAA"

Section "Screen"
        Identifier      "Default Screen"
        Device          "Radeon 9600"
        DefaultDepth    24
        SubSection "Display"
                Depth           24
                Modes           "1680x1050" "1440x900" "1024x768"

Section "DRI"
        Mode 0666

Section "Extensions"
    Option "Composite" "Enable"


I just had it happen again. I tried unplugging the DVI cable from the back of the computer and then plugging it back in. The monitor then displayed the desktop properly. I'm not sure if that makes a difference or not in what I may need to change settings-wise.

share|improve this question
Does your monitor have a source button? It sounds like it's looking for a VGA signal and not bothering to try DVI until it's unplugged and plugged back in. – Emory Bell Mar 27 '10 at 13:38
In the monitor menu (the one brought up by pressing the buttons directly on the monitor) there is a menu that shows Analog, Digital and DDC/CI [on or off]. It's set to digital and DDC/CI is set to on (not sure what the DDC/CI stands for... I guess I can Google that one). I did just notice there is also a reset in the menu. I wonder if selecting that would fix the issue rather than unplugging it. That would just be fixing the symptom though, not the source of the problem =\ – Jason Down Mar 27 '10 at 13:42
So much for the reset idea. The menu doesn't show up when the input not supported message is bouncing around. – Jason Down Mar 27 '10 at 13:44
Wikipedia: DDC - The Display Data Channel or DDC is a collection of digital communication protocols between a computer display and a graphics adapter which allows the display to communicate its supported display modes to the adapter and adjust monitor parameters such as brightness and contrast from the computer host. DDC/CI (Command Interface) specifies a means for a computer to send commands to the monitor, as well as receive sensor data from the monitor, over a bidirectional link. Specific commands to control monitors are defined in a separate Monitor Control Command Set (MCCS) standard. – Jason Down Mar 27 '10 at 13:47

Depending on whether your Xorg is recent and ignores this file, the video driver in use with your Radeon, and whether the monitor communicates correctly over DDC, you might need to try a few things to make this more pleasant.

First, you might want to bind a shortcut in your window-manager/desktop-environment that makes the display go to sleep for you. This will solve your problem without fixing the issue, which is a nice and hackish way to go about it. Something like xset dpms standby, or xset dpms suspend might work.

There are also some xorg.conf options specific to the driver in use, like Option "MonitorLayout" "NONE, CRT" for specifying what output is in use, and what is expected to be found there; or Option "DPMS" "true" to make sure Xorg knows you want it to talk to your monitor. You might want to look into those wrt the driver in use.

share|improve this answer
I'll have a look, thanks for the suggestions. – Jason Down May 15 '10 at 3:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .