Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using TextMate on Snow Leopard, don't know much about how it works. After I hit an unknown keyboard shortcut, it suddenly decided to highlight almost all text in my Python files dark red - making all my Python virtually unreadable!

I must have accidentally pressed a shortcut - but I've no idea what I did or how to turn it off, and can't find any relevant help in the manual or form. Even just 'turn off all highlighting' would do.

Anyone know how to turn this highlighting off? Bit desperate!

share|improve this question
add comment

migrated from stackoverflow.com Mar 27 '10 at 22:36

This question came from our site for professional and enthusiast programmers.

1 Answer

Figured it out. There's a tiny, tiny dropdown list at the very bottom of every TextMate editing window where you can set the language, so TextMate can highlight invalid syntax - I'd accidentally clicked on it and set the language to something other than Python. Will leave the question up though in case others have the same problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.