Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Can you please tell me how can I resolve these dependencies on ubuntu:

checking for GSTREAMER... configure: error: Package requirements (gstreamer-0.10 >= 0.10
                     gstreamer-app-0.10
                     gstreamer-base-0.10
                     gstreamer-pbutils-0.10
                     gstreamer-plugins-base-0.10 >= 0.10.25
                     gstreamer-video-0.10) were not met:

No package 'gstreamer-app-0.10' found
No package 'gstreamer-pbutils-0.10' found
No package 'gstreamer-plugins-base-0.10' found
No package 'gstreamer-video-0.10' found

I have tried:

$ sudo apt-get install *gstreamer-video*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Regex compilation error - Invalid preceding regular expression
$ sudo apt-get install *gstreamer-app*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Regex compilation error - Invalid preceding regular expression
$ sudo apt-get install *gstreamer-base*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Regex compilation error - Invalid preceding regular expression
share|improve this question

migrated from stackoverflow.com Mar 28 '10 at 6:35

This question came from our site for professional and enthusiast programmers.

3 Answers 3

$ apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev

which you could have found by doing a search for gstreamer-app-0.10.pc in package contents on packages.ubuntu.com or with apt-file search, or by running the whole configuration process within auto-apt run.

share|improve this answer
    
This worked for me on Ubuntu 13.04 –  freddyb Aug 12 '13 at 9:15
    
This worked for me on Ubuntu 12.04 –  SSumner Sep 16 '13 at 19:10
    
This also worked for me on Ubuntu 13.10 and your answer should be marked as the correct one. –  Voitek Zylinski Nov 4 '13 at 0:21
    
This worked for me on debian! :) –  neo1691 Mar 16 at 14:35
    
This worked for me on Ubuntu 14.04 –  tkcsam May 8 at 16:47

Try

apt-get install libgstreamer*
share|improve this answer
    
Thanks . I tried that. But still same error. I have tried '$ sudo apt-get install libgstreamer*-dev' but it does not work. –  michael Mar 28 '10 at 1:38
    
Tried this too, but cant install or find decklinksrc –  YumYumYum Sep 23 '11 at 23:09

I have tried that '$ apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev'

But it now said:

Requested 'gstreamer-plugins-base-0.10 >= 0.10.25' but version of GStreamer Base Plugins Libraries is 0.10.18
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GSTREAMER_CFLAGS
and GSTREAMER_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

So download and 'make install' gstreamer in /home/michael/bin (./configure --prefix-/home/michael/bin).

And the I have set

$ echo $PKG_CONFIG_PATH
/home/novarra/bin/lib/pkgconfig
$ echo $GSTREAMER_LIBS
/home/scheung/bin/lib/pkconfig

And rerun ./autogen.sh --enable-debug

I set get the same 'Requested 'gstreamer-plugins-base-0.10 >= 0.10.25' but version of GStreamer Base Plugins Libraries is 0.10.18'

share|improve this answer
    
michael, you need to associate your accounts in your user profile (see meta.stackexchange.com/questions/18232/…). then you'll regain ownership of this question. –  quack quixote Mar 28 '10 at 22:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.