Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm am trying to enable the boot timeout selection in grub2 on Ubuntu 9.10.

I modified /etc/default/grub:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="splash quiet"
GRUB_CMDLINE_LINUX=""

and ran update-grub, but I still do not have a boot timeout counter. What else can you do to enable this?

share|improve this question

2 Answers 2

up vote 5 down vote accepted

Answer taken from http://ubuntuforums.org/showthread.php?t=1373965

at the end of your /etc/grub.d/00_header file, comment out the if condition except for the regular set timeout line like this:

#if [ \${recordfail} = 1 ]; then
#  set timeout=-1
#else
  set timeout=${GRUB_TIMEOUT}
#fi

run update-grub to regenerate the grub.cfg with the new settings:

sudo update-grub

reboot, now it should always boot the default option after the timeout, even if the previous boot failed.

share|improve this answer
    
thanks, this is helpful –  Casey May 1 '12 at 21:36

The problem was related to a the grub env value: recordfail. I was able to resolve with the following command:

grub-editenv /boot/grub/grubenv unset recordfail

Another option that will guarantee the timeout will always work:

rm /boot/grub/grubenv

If you don't do this, grub might re-write the recordfail value. I needed this for an embedded system.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.