Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Today when I tried to run an old DOS utility from the XP Command prompt, I got the message "Access is Denied." Then I found that most of the DOS utilities would not run, even though I have "full control" over them. They worked just fine a few weeks ago, and I have not made any OS changes other than Windows Upgrades.

Then I tried running edlin.exe and from the Windows\system32 folder. Same result - "Access is Denied." I tried running these applications from Windows Explorer and got the message "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item."

I am logged in as a member of Administrators and have full control over these files. I tried logging in as THE Administrator, with no change. I checked the security settings on the files, and have full control over all of them. I have tried copying the files to different drives, booting in safe mode, and running without antivirus and firewall, all with no change.

Does anybody know what could cause this?

share|improve this question
up vote 1 down vote accepted

What are your access rights to NTVDM.EXE? (this is the component which runs DOS and win16 programs)

I suggest using Process Monitor to find out exactly which process is trying and failing to access which file.


Looking at the results of Process Monitor, it looks like you've got the "Prevent access to 16-bit applications" policy set. To fix it, Start -> Run, "Gpedit.msc". Navigate to Computer Configuration -> Administrative Templates -> Windows Components -> Application Compatibility and look at "Prevent access to 16-bit applications" in the right-hand pane. If it says Enabled, change it. Otherwise, look for the same policy under User Configuration.

share|improve this answer
I have full control over ntvdm.exe. I tried Process Monitor, but I don't understand most of the output. There are about 315 items, including 106 errors, that occur when cmd.exe tries to execute d:\util\zip.exe. There are 91 "name not found," 12 "path not found," 2 "no more entries," and a "buffer overflow." I uploaded all of them to . Is this normal? – xpda Mar 29 '10 at 3:31
OK I've updated my answer (I'm guessing you don't get notified of an edit, hence the comment) – Hugh Allen Mar 29 '10 at 4:48
That's it -- Thanks!!! Out of curiosity, where did you find that in the process monitor output? Also, do you know of any ways that could have been inadvertantly changed? – xpda Mar 29 '10 at 5:02
One possible way: did you follow the advice in the last paragraph of this article:… ? (note that MS released a patch so there's no longer any reason to disable NTVDM) – Hugh Allen Mar 29 '10 at 6:25
No, I have never intentionally changed any policy settings on this system. I may have to chalk this one up to Gremlins. – xpda Mar 29 '10 at 14:39

Are you running the command prompt as administrator though? I think it's Vista/7 and maybe XP you have to state that you want to run command prompt in administrator mode, even if you're logged in as an administrator. In Vista, I think it's simply right click->run as administrator (the go through UAC if it's on)

share|improve this answer
That crossed my mind too, but the way the question is phrased implies that previously the utilities did work. Though, of course, I could be reading more into the question than is really there. – ChrisF Mar 28 '10 at 23:07
The utilities used to work and do not now. I have logged in as Administrator, and tried run-as-administrator with no change. – xpda Mar 29 '10 at 3:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .