Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got a wireless broadband modem (Huawei E1750) hooked up to my computer (call it A., running Windows-7) whose internet I wish to share to my other computer (call it B., also running Windows-7).
A. is hooked up to my d-link DIR-600 router using a wired connection to port 1 on the router.
B. is connected to the router using a wireless connection.

Now I have tried setting up the sharing according to the help files for ICS but I have not been able to get it working. I suspect that there is something in my hardware configuration that is making it difficult.
I would appreciate some tips and pointers as to what could be the reason to my problems.

share|improve this question
up vote 1 down vote accepted

When you enable Internet Connection Sharing in Windows, it tries to act as a NAT gateway and DHCP server. Your D-Link DIR-600 probably tries to provide both of those services by default as well, and conflicts with what your Windows-7 "A" box is trying to do. So make sure you disable those services on the D-Link router (some similar products call it "bridge mode" when you have NAT disabled).

By the way, does your "A" box lack an 802.11 card? Or does your "B" box lack an Ethernet port? I'm wondering why you have the D-Link box in the picture at all. The only reason I can think of for having the D-Link box there, from what you've told us so far, is if you need it to act as a wired-to-wireless Ethernet bridge, which makes me think your "A" box must not have an 802.11 card of its own.

share|improve this answer
I.e I should let the router act like a switch instead? I'm gonna try your suggestion when I get home. Sounds like it should work. I do have wireless on both boxes but I also (not mentioned in my description) have a NAS (Mybook) hooked up to the router. But if your first suggestion doesn't work I will try this as a temporary fix. Worst comes to worst I can get crossed tp-cabel and hook the NAS into A. instead. – Skadlig Mar 29 '10 at 7:25
Yes, "bridge" and "switch" mean the same thing in the context of Ethernet. – Spiff Mar 29 '10 at 9:19
The first suggestion worked like a charm. Thanks – Skadlig Mar 29 '10 at 16:26

Plug the modem into your router WAN port. Let it handle sharing your internet connection. You can turn ICS off.

share|improve this answer
His Huawei E1750 wireless broadband modem is a USB dongle. His D-Link DIR-600 doesn't have USB. – Spiff Mar 28 '10 at 22:21
Spiff is correct, my modem is a USB dongle. Sorry, maybe I should have mentioned that in the text. – Skadlig Mar 29 '10 at 7:27
oh my bad - I didn't realize that. Thanks Spiff. – AJ Bovaird Mar 29 '10 at 17:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.