Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How to disable the power management in fedora 12, so that lcd/monitor should not go to sleep/off when system is idle?

share|improve this question
up vote 2 down vote accepted

Following are commands to successfully disable the Power Management in Fedora

The following will set DPMS(Display Power Management Signaling) parameters

xset dpms 0 0 0

The three zero values represent three different modes

First zero disables the standby mode

Second zero disables the suspend mode

Third zero disables the force mode

The following will disable the screensaver

xset s off

For details please see

man xset

share|improve this answer

Do you want to just disable this sometimes?

What desktop environment are you using? Gnome has Gnome-power-manager, which allows you to control how the monitor behaves when the machine is idle. In KDE, powerdevil is part of the base, so opening the systems settings (Advanced tab) should get you to the power management settings.

An extreme approach would be to turn off APM and ACPI completely. Turning off APM and ACPI will disable all power management on your computer - on a laptop, you are going to kill your battery performance. That said...

To do it only once:

  1. When you first start your computer, you get the GRUB screen. Press ESC.
  2. Add apm=off acpi=off to the end of the line that appears, and press enter. If acpi=on exists, then delete it.

If that works, you can make it permanent:

  1. Become root (su -)
  2. Edit /etc/grub.conf
  3. At the end of the line that starts with kernel, add apm=off acpi=off (remove acpi=on)
  4. Save & restart.
share|improve this answer
no effect of apm=off acpi=off. same behaviour as before. – MA1 Mar 30 '10 at 4:46
what window manager & desktop environment are you using? – DaveParillo Mar 31 '10 at 3:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .