Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use the rest-client to test REST APIs. It is basically just a .jar file, that is called via java -jar rest-client.jar. The rest-client uses two file extensions, in my case .rcq, to store data in files.

I want to let the explorer open .rcq files with java -jar rest-client.jar <infile>, however, if I configure it (via GUI) to use the JAR alone, it obviously doesn't work. I'd be fine with touching HKEY_CLASSES_ROOT for this, as well, but don't know the exact syntax.

By the way: It's WinXP.

share|improve this question
up vote 4 down vote accepted

In two steps:

  1. Open Explorer, right-click an .rcq file and choose Open, then Select from list, choose java.exe and click OK after checking "Always use the selected program".

  2. Still in Explorer, open Tools -> Folder options, File types tab, click on .rcq in the list, then Advanced. Click on Open, then Edit, and add the additional parameters to the displayed command.

share|improve this answer
    
This works on my Vista machine (+1). Unfortunately, here I'm stuck with WinXP "Home" (which, in my experience, basically means: "Ey, user! You're so ignorant, we don't give you any advanced controls via GUI"), otherwise I'd accept the answer. – Boldewyn Mar 29 '10 at 14:46
    
@Boldewyn: One can also do the same thru the registry. Which step doesn't work for you? And do you have regedit in Home (there are alternatives if not). – harrymc Mar 29 '10 at 14:52
    
You may also copy the registry entries from the Vista machine to XP. Start with HKEY_CLASSES_ROOT\.rcq which will probably point to rcqfile, so you also need HKEY_CLASSES_ROOT\rcqfile. Dump them to .reg files and double-click on them in XP to enter into the registry. – harrymc Mar 29 '10 at 15:21
    
Thanks for the hints. There was a key rcq_auto_file instead of rcqfile, that I needed to change, but else editing the registry worked just fine. – Boldewyn Mar 30 '10 at 7:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .