Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was having a problem with missing fonts in Flash CS4, so I cleaned the font caches using the following commands in Terminal:

sudo atsutil databases -remove
atsutil server -shutdown
atsutil server -ping

These commands ran fine, so I restarted and opened my Flash file. Now suddenly Verdana is missing in Flash which was previously there.

  • I ran FontNuke, and cleaned caches, and rebooted. Still nothing showed in Flash.
  • I ran Cocktail, and cleaned just the font caches (all users on system), still nothing in Flash.
  • I reinstalled Flash (didn't work)
  • I then uninstalled Flash, rebooted and installed Flash, rebooted. (didn't work)

After all this, Verdana still doesn't load in Flash. I validated all fonts in Font Book and removed the erroneous fonts.

Is there any other way I can have all the fonts load in Flash (eliminate another cache I am not seeing)? I am so sick of Flash and its font caches and Verdana is pretty much a standard font so what am I doing wrong here?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

This is where the answer lies: http://forums.adobe.com/message/2558650#2558650

It is a nuisance doing it this way, but it was the ONLY method that worked for me.

  1. Firstly, close Flash.
  2. Move all fonts from /Library/Fonts & ~/Library/Fonts to a folder on your desktop.
  3. Start up Flash again, try opening the file which uses the missing fonts. (You should get the Font Replacement dialog now), click Cancel.
  4. Quit Flash.
  5. Move the .ttf/.otf files of the missing fonts (missing in Flash) back to /Library/Fonts, but only them, not the rest.
  6. Start Flash up again with the .fla in question, your fonts should all be found now and render.
  7. Quit Flash, move the rest of the font files back to /Library/Fonts (did not test it with User fonts i.e. ~/Library/Fonts, I suppose it would be just same copying them back to ~/Library/Fonts)
  8. Open Flash again and all missing fonts should now be visible in Flash.

This is the ONLY method that worked for me!

share|improve this answer

Have you tried the steps specified by Adobe?

http://kb2.adobe.com/cps/167/tn_16763.html

share|improve this answer
    
Thanks, but I am running Snow Leopard, and those files can't be found anywhere, or anywhere I am looking rather... Do you know where they are located, as the images on Adobe's website don't show up? –  Anriëtte Myburgh Mar 30 '10 at 11:21
    
I Googled a Snow Leopard solution but couldn't find anything more recent on Adobe's site. Apparently the 10.0.2 update for Flash CS4 fixes this. Do you have this installed? –  ta.speot.is Mar 30 '10 at 21:24
    
Yes, I have. I also thought that would fix it, so I installed that first. –  Anriëtte Myburgh Mar 31 '10 at 5:52
    
Alas, my problems are still present in Flash. I don't know anymore ways on how to fix this. –  Anriëtte Myburgh Apr 12 '10 at 6:08
    
I see you have found a solution. The other option is to contact Adobe, since they are the vendor and as you paid for their product you are entitled to a degree of support. –  ta.speot.is Apr 12 '10 at 10:09

After 4 font management applications (trying to clear system and Adobe font caches), it was fixed. I tried:

  1. FontNuke
  2. Font Finagler
  3. Cocktail
  4. FontExplorer Pro

Finally, FontExplorer Pro was the one that came through for me.

Conclusion: I hate Flash

share|improve this answer
    
Sad to say, but FontExplorer Pro did not return all the fonts. –  Anriëtte Myburgh Apr 13 '10 at 5:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.