Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Here's the problem:

  • I want to use Ubuntu.
  • But I need to develop ASP.NET (MVC) sites.
  • So I setup VirtualBox with Win2003 and IIS6.
  • But I would prefer my working files to be located in my Ubuntu home folder.
  • So I setup shared folder in VirtualBox and make IIS6 virtual directory work from there.

The problem is, IIS6 can't do this. Whatever I try (mapped drive, network uri path) I get different IIS errors: can't access folder (for mapped drive), can't monitor file system changes (\vboxsvr share path), and so on.

Is there a way for IIS6 in virtual machine to configure virtual application folder to be on host machine (Ubuntu) - be it shared folder, mapped drive, smb share, or whatever?

Here's what I got using mapped drive:

HttpException (0x80004005): Server cannot access application directory 'h:\work\web\'. The directory does not exist or is not accessible because of security settings.]

And this is using network share path option in IIS:

[HttpException (0x80070001): Failed to start monitoring changes to '\vboxsvr\queen3\work\web

UPDATE: also, to avoid "Failed to start monitoring changes" one may consider this method (disable ASP.NET monitoring file changes). This will allow to use VirtualBox shared folders, not only samba shares. This also helps to debug apps from Visual Studio using run (F5), only solution has to be open from share, not mapped file (\vboxsvr\share).

share|improve this question
Permissions on the share perhaps? – mindless.panda Mar 30 '10 at 12:36
OK, where do I setup permissions on VirtualBox shared folder? – user17859 Mar 30 '10 at 12:37
Note that I can use this share, write files and build solution using Visual Studio. But IIS can't. – user17859 Mar 30 '10 at 12:37
I'm finding some hits, start here: – mindless.panda Mar 30 '10 at 12:39
and… – mindless.panda Mar 30 '10 at 12:41
up vote 3 down vote accepted

It may be an issue with how virtualbox is sharing the folder using the special vboxsvr name. Try sharing the folder on Ubuntu using Samba and then mapping it in the virtual machine using the IP address instead.

share|improve this answer
I get the same 0x80004005 directory access exception when using mapped drive for smb share on Ubuntu. However if I configure IIS to use share path (\\ubuntu\share) I can get past my errors and get "PolicyException: Required permissions cannot be acquired" - which is a step further, thanks. The policy exception is probably about full trust since the assemblies are on network share... – user17859 Mar 31 '10 at 8:45
That's right, this link… helped me to avoid PolicyException. Now I get SecurityException about partially trusted callers, oh boy ;-) But that's a different story. In short SMB share worked. I wonder if VBox share can be setup this way or this was because of Ubuntu access rights to home folder... – user17859 Mar 31 '10 at 8:59
would be greate if you post your smb.conf, or the important sections, – nelaar Jul 19 '11 at 13:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .