Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried this both on Windows 7 and Snow Leopard (Mac OS X 10.6).

While vrdpauthtype null works (everyone can connect to VMs without user name/password) vrdpauthtype external doesn't work (and RDC connections are just rejected).

Did anyone ever get this to work?

share|improve this question
I'm having the same problem on WinXP. It seems all the authentication methods are unix only. – Fake Name Jun 21 '10 at 0:00
Which version of VBox are you running? And can you confirm that you're connecting to the host (on the set VRDP port) and not trying to RDP to the the guest? What error message do you get when using external authentication? – ItsOnlyOneLineOfCode Jun 21 '10 at 16:39
I'm running Virtualbox 3.2.4 (The latest version). I am definitely connected to the host, as I can see the Virtualbox POST screen. When set to any of the other Auth types, the RDP session opens and immediately closes, with no error message at all on the server. – Fake Name Jun 22 '10 at 3:44
To clarify, virtualbox starts without issues when set to External or Guest authentication. However, any RDP session immediately terminates when you connect to the RDP server, with the "Your remote desktop session has ended" Message. – Fake Name Jun 22 '10 at 3:47
up vote 1 down vote accepted

Ok, I've solved the problem.

For some reason, the "External" Authentication method only works when you select "Allow me to save credentials" in the RDP initialization window on the client end.
Otherwise it fails with the "Your RDP session has Ended" message.

Is there any way to make this work without saving credentials? It's a bit of a security hole.

share|improve this answer
Yes, the connection is required to transmit user name and password immediately as there is no system to connect to without authentication. Problem with earlier version of VirtualBox was that auth library was missing for Mac OS X. – Andrew J. Brehm Jun 22 '10 at 9:11

In Virtualbox version 4.1 the RDP server requires that you install the VirtualBox Extension Pack before you can connect to a guest using RDP. The settings are there, but without the extension pack the RDP server will not start. You can find additional information in the online user guide under the VirtualBox RDP Authentication - Null, External, and Guest settings section.

share|improve this answer
I don't think your answer is relevant though. At the time the original question was posted, the extension system didn't even exist and the problem is still there with 4.1 with the extension installed. You still have to save credentials for VRDP to work on MSFT clients... – Jul 26 '11 at 22:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .