Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don't know why, or how... but my Ubuntu's loading / booting stops right after the Ubuntu logo appearing.. An underscore appears in the right top of the screen:

_

then, it disappears leaving the whole screen black

Version is 9.10, Kernel is .20

I have tried recovering mode and selected recover damaged packages option, but it didn't do any good..

I have very important files in Ubuntu that I need to copy to a pen drive or something, today.. The terminal mode is working, so i think i can do this there..

My questions: How can I get my Ubuntu to load? Is it possible to copy the files i need via terminal mode?

I dont know if with other of the previous kernels it would work... but I had configured my grub (inside Ubuntu's gui) to show only the last kernel... and now i can't select any other kernel then .20 because I don't know a way to configure Grub unless via Ubuntu's gui...

My hardware: ATI Mobility Radeon 4650 HD

P7450 2.13Ghz Core duo

4Gb DDR2

share|improve this question
    
Wait a second...dropping to the recovery console works, but a normal boot does not? –  Bobby Mar 31 '10 at 14:07
    
yes, why? is that strange? –  joxnas Mar 31 '10 at 19:49
add comment

4 Answers 4

I think the first thing to worry about is getting your stuff copied off the machine...

If you have a Live CD, boot using that and you should be able to copy things onto your pendrive easily enough...

If not, then you should be able to do it in the terminal mode, but it may be a bit awkward if you are not used to it.

Boot into terminal mode and log in.

You will need to become root, enter the command

sudo su

followed by your password.

Make a directory where your pen drive will be mounted, by entering the command

mkdir /media/pendrive

Place your pen drive in the computer, then enter the command

dmesg

You will get a scrolling list of all the computer messages since booting; at the bottom will be some messages about you pendrive looking something like [sdb] Attached SCSI removable disk. You need the sdb part, which may be different on your machine. If so replace that in the following command, which will mount your pendrive

mount /dev/sdb1 /media/pendrive

(I am assuming that there is only the one partition on your pendrive.)

You can now use the normal Linux commands to navigate around and copy your files. (ls to list files, cp to copy etc - if you haven't use them, a qiuck Google should help you.)

In particular, the following command will copy all your files to the pendrive

cp -r /home/USERNAME/ /media/pendrive

Unmount the pendrive before taking it out of the machine

umount /media/pendrive

Shutdown the machine with

shutdown -h now

(It would be a good idea if you waited until a few people have read this and pointed out my errors.)

share|improve this answer
    
Thanks I've managed to copy the important files using the Live CD –  joxnas Mar 31 '10 at 19:26
add comment

(This answer has been updated.)

Ubuntu includes a recovery mode. You can either modify the GRUB config from single user mode, or boot from the install or Live CD/DVD/USB media and type rescue at the boot: prompt.

See Ubuntu's Grub2 page for more information about boot options, and accessing them for Karmic Koala (9.10) and later.

If you run the "Try Ubuntu without any changes to your computer" option from the install / Live CD, you will be able to see the hard drives on your computer, assuming that the hard drive(s) and the file systems themselves are not seriously damaged.

You will be able to backup any important files, and then re-run grub install - the link includes good instructions to walk you through updating or re-installing any GRUB configuration files that need to be fixed. You can also review the log files (e.g. /var/log/syslog, /var/log/messages, /var/log/boot, /var/log/kern.log, /var/log/dmesg, and /var/log/dpkg.log) to see if you can determine what is failing.

I hope this will get you further on recovering the system with no data loss, and a working boot process.

share|improve this answer
    
I didn't understand how can I access the boot prompt.. I typed rescue in the recovery mode but it said the command was unrecognized. I tryed to boot from the install CD i have (Ubuntu 9.04) but I dunno where Can I write "rescue"... I pressed F1 while in the boot MENU of the install cd... and I found something saying that the disk I'm using doesnt have rescue mode.. Help! –  joxnas Mar 31 '10 at 19:31
add comment

It's probably an issue with your partitions. Boot up a live CD, and go to System -> Administration -> Disk Utility and click Check Filesystem. Alternatively (or if using an older version of Ubuntu), you can go to a terminal and type sudo e2fsck /dev/sda1, where /dev/sda1 is the device that your ubuntu partition is. If you're not sure, go to System ->Administration -> Gparted, and find the partition name. It'll ask you a bunch of questions, just say 'yes' to all of them. You may find you're then able to boot.

While you're in the LiveCD, you ought to be able to mount your disk and copy your files to a flash drive or external hard drive or something similar. Just go to Places and load your hard drive, then do the same for the backup location.

share|improve this answer
    
Done it with the e2fsck thing.. but didn't solve anything. thanks, anyway –  joxnas Mar 31 '10 at 19:25
add comment
up vote 0 down vote accepted

I managed to solve everything. First, I did as many told me to: Boot from the live CD, try ubuntu without install, mount my linux drive, backup important files, etc ...In case anything went wrong

Second: In my grub MENU, I only had the last kernel used to show (Because I had it configured that way). But I could edit the boot command by pressing 'e' and editing the kernel number to 19.

Third: I pressed 'b' to boot with this command. The result: An horrible graphics (weird inverted pixelized colors, you know...) ubuntu. But it was MY ubuntu. So I was able to reconfigure the GRUB seetings from there by going to system->Administration->Start-up manager. and make GRUB menu to show all the kernels.

When I rebooted, I used .19 kernel (I think) and it was working. I reinstalled my graphic card's drivers and rebooted again with the kernel .20 . And it worked nicely :)

After so many stuff, I also decided to upgrade to 10.04. I know it's beta but I thought the upgrade could bring some stability to the system. Now I just need to find the drivers for my graphic card for 10.04, but that will be maybe be another question...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.