Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When clicking to follow hyperlinks from Excel, I'm now getting this error:

Unable to open http://blah... Cannot download the information you requested.

The hyperlinks in the Excel file are created using the HYPERLINK() formula.

I use Google Chrome as my default browser. The web site in question uses Basic Authentication, and I've entered correct credentials when prompted (the dialog looked like an IE auth box, not Chrome's, but it's always been that way, even when it was working properly).

This hasn't been an issue until recently. I'm guessing our IT department made some lame change to IE's configuration that is causing Office to not be able to open the URLs, despite having Chrome as my browser.

Things I've checked already:

  • URLs are good, they work fine when pasted manually into Chrome, IE, or Firefox.
  • IE is not set to Work Offline (already found that suggestion on Google).
  • I checked Program Access and Defaults and verified that Chrome is selected.
  • Nothing in the URL requires URLEncoding, so it's no goofy issue with encoding

I've had reports from some other users now and then about the same problem, but this is the first time I've experienced it myself.

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I found this which implied that the HTTP response might not be a standard 200, and that Excel might not be able to handle it.

Two ways to check out this theory:

  1. (Easier, but less precise) Try changing your link to a link that you know will return a proper 200 HTTP response. http://google.com seems to without any redirects or anything. See if you can click on that link and see if the link works.
  2. (Requires software installation, but gives you more detail) If you have rights to install software, install a proxy like Fiddler to see what's happening under the hood. See if the request actually makes it out of your box, and what the response code is that comes back.

Given that you said the site uses basic authentication, you will probably be getting a different response anyway (401 Authentication Required, I think) so this might not be the case.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.