Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I upgraded from Fedora 10 to Fedora 12. Unfortunately, my ethernet interface eth0 is now named eth0_rename. I'd like to get back to having it named plain old eth0.

I googled a bit but the solution of removing the eth0 entry from /etc/udev/rules.d/70-persistent-net.rules seems to have no effect (I restarted the network service but didn't reboot).

The interface works just fine although I could see a script or two having a problem with the format. So, it's more of an inconvenience thing than anything else.

Any ideas?

share|improve this question
You need to restart udev instead of your network service since it is the one taking care of device names (among many other things). – Benjamin Bannier Mar 31 '10 at 18:05
So a reboot should take care of it. Thanks. – shank Mar 31 '10 at 18:14
up vote 1 down vote accepted

The answer is...

remove the corresponding interface lines from /etc/udev/rules.d/70-persistent-net.rules and then reboot your machine. Voila, simple eth0, etc interface names again.

I suppose I should have rebooted before asking the question but at least now the question and answer are here for others.

share|improve this answer
Nice it worked ;) So mark your own answer as right. – Benjamin Bannier Mar 31 '10 at 18:57
Since I posted it and answered it I have to wait a couple days before I can mark it as the answer. Don't want to artificially build myself up I guess. Thanks Honk. – shank Apr 1 '10 at 16:50

I had a similar problem when cloning a virtual machine. Removing the rules didn't work. However, updating the existing rules to match the new MAC addresses worked. It tried to make new rules for the new interfaces, but it didn't recognize that the old interfaces were gone. It's an ugly bug.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.