Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've exhausted my ability to search through Google for this, so I'm giving it a go here.

What I'm trying to do is increase the resolution (or decrease the font size) in the TTY terminals. Xubuntu 9.10 uses GRUB2, and everywhere I can find directs me to edit the

/etc/default/grub

File in order to add vga=XXX to the GRUB_CMDLINE_LINUX value, and this simply doesn't work. Out of endless fiddling with the file, nothing ever seems to change.

On my Netbook running an earlier version, I had success with this command

dpkg-reconfigure console-setup

But once again it yields no change.

Got any ideas?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

I was looking for a way to do this for an Ubuntu 9.10 guest in VirtualBox, and got about halfway there. In my VM, the console TTYs get the correct resolution if I boot into single-user mode, but not if I boot into GDM.

Grub2 replaces the vga=XXX kernel option with a gfxpayload option that can be set in /boot/grub/grub.cfg. Ubuntu's update-grub command automatically generates grub.cfg from variables in /etc/default/grub and scripts in /etc/grub.d, so the best place to add this option is in one of those two places.

These are the Grub2 options (in grub.cfg syntax) that affect the console resolution:

  • gfxmode: Sets the resolution of the Grub menu.
    eg: set gfxmode=1280x800 (no explicit bitdepth)
    eg: set gfxmode=1440x900x32 (explicit bitdepth)

  • gfxpayload: Sets the resolution Grub passes to the kernel.
    eg: set gfxpayload=1024x720x16
    eg: set gfxpayload=keep (keeps resolution as set in gfxmode)

On my system, I added some scripting to the /etc/grub.d/00_header to support a new GRUB_GFXPAYLOAD variable that's specified in /etc/grub/default. This isn't strictly necessary, and there are lots of ways to do it; see the examples on the Debian and Ubuntu forum links below.

Sources:

share|improve this answer
    
A +1 for you for such a comprehensive answer, but I've still yet to get this thing to change in any way. Bigger, smaller, GRUB menu or the TTY itself. AGH! –  Zurahn Apr 1 '10 at 21:51
    
@Zurahn: yeah, i played around with it some more after jotting up this answer, and my VMs aren't any closer to what i want to see. one of the Ubuntu Forums links suggests replacing the linux and initrd commands with linux16 and initrd16 (and then using the older vga= syntax) but i haven't found any modes that that works properly with. :( –  quack quixote Apr 2 '10 at 4:53
1  
I finally got a solution: reverting to legacy GRUB. ubuntuforums.org/showthread.php?t=1298932 –  Zurahn Apr 14 '10 at 0:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.