Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Now my script is able to start server, But I am still have some problem with my script.

When the start server command is executed, the control does not pass the line and does not execute further of that line.

Please tell me what is the problem and how can I get smooth execution of the my script.

My Script:

SUBIT="su - adminuser -c "
SERVER_BOX_COMMAND_A="Server"

##############
# Function to start cluster

function start(){

   $SUBIT "$SERVER_BOX_COMMAND_A"

   doFurther 
}

doFurther (){
    #tasks after server is started
}

case "$1" in
start)
    start
   ;;
stop)
   stop
  ;;
restart)
   $0 stop
   $0 start
   ;;
*)
   echo "usage: $0 (start|stop|restart)"
   ;;
esac
share|improve this question
    
We're going to need to see the script to help you :) –  John T Apr 1 '10 at 5:49
    
Updated my question and added shell script. –  vijay.shad Apr 1 '10 at 6:03

1 Answer 1

up vote 1 down vote accepted

works as designed? "su adminuser ..." is running and will call doFurther when finished. May be you wanted to put $SERVER_BOX_COMMAND_A in the background? Just add an ampersand, so that the final command looks like: su adminuser -c "..... &".

I hope this helps, Klaus

share|improve this answer
    
Thanks sir, It works. –  vijay.shad Apr 1 '10 at 7:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.