Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to sync a first gen iPod Touch to my PC running Windows 7 64 bit. The problem is that whenever I connect the iPod, iTunes completely freezes (if I start iTunes after connecting the iPod it will simply hang until it's physically disconnected from the PC).

I reinstalled iTunes thinking that it had been corrupted, but without any luck. I've had this problem with all the latest versions of iTunes. I've also tried using MediaMonkey and DoubleTwist. None of these apps see the iPod as being connected; DoubleTwist also freezes, just like iTunes.

The really strange thing is that I was able to sync the iPod with this PC a while back, but I now seem to have lost that ability. I don't know what changed. Windows detects the device every time it's plugged in (I can see it in Device Manager and I can browse all photos on iPod as if it were a camera). Also, I can sync it to iTunes on Mac OS X without any major problems.

Edit: after getting similar behavior in Windows XP (I got an 0xE8000065 error message), it seemed less and less like a driver issue. So I did the following:

  • a second restore from a Mac (without restoring the backup that was made in the process!),
  • changed the USB port (again), <-- this is mostly out of paranoia, but it doesn't hurt to try it (it might be a problem, you can never know)
  • reinstalled iTunes (again), making sure that the drivers were correctly installed. Look in Device Manager; there's an entry in USB devices called Apple Mobile Device USB Driver (the physical file is called either USBAAPL.sys or USBAAPL64.sys, depending on your OS). This entry might not appear if the iPod/iPhone is unplugged.
  • ???
  • Profit! It worked!

I have no idea why it worked this second time (I had done all these steps before, but without any luck; it probably has to do with the fact that I did the restore, but I also had iTunes copy the backup onto the iPod after finishing), but it did. iTunes recognized the iPod as an iPhone (?!), but it correctly configured it as an iPod Touch. Now everything seems to be working.

I've marked Matrix Mole's answer as accepted since the restore probably solved my problem.

share|improve this question
Do you know if you've had a Windows update since? Maybe one of the patches conflicts with the iPod. – random Apr 1 '10 at 9:00
@random Could be. Most of my software is up to date, so one of the patches could have broken something. It might have been an iPhone OS firmware update as well. – alex Apr 1 '10 at 9:06
Is your iPod jailbreaked? Heard that iTunes 9.1 can cause some problems on jailbroken devices. – Fogh Apr 6 '10 at 11:32
@Fogh no, it's never been jailbreaked. – alex Apr 6 '10 at 13:24
BTW Did you check the cables? Just a thought. While back I had a problem with my external HDD and replacing the Cable fixed the issue. – THEn Apr 6 '10 at 22:42

14 Answers 14

up vote 1 down vote accepted

Not sure if you already did this or not. You can try to restore the iPod on the OSX machine, then see if it'll work with the iTunes install on the windows machine. This will lose all data currently stored on the iPod, so make sure to backup anything that isn't synced through iTunes before hand.

No guarantee that it'll work, but it's worth a shot.

share|improve this answer
I tried your suggestion, but nothing changed, sadly. +1, anyway – alex Apr 4 '10 at 17:50
I've marked your answer as accepted since the restore is probably what solved my problem. See the edit to my question for more details. Thank you! – alex Apr 8 '10 at 6:34

I ran into a problem like this where my company added a network drive that was the same drive letter the ipod wanted to be.

It was a silent push so i didn't even look for it. after removing the drive everything worked fine.

If that doesn't work try doing a factory reset on the ipod.

share|improve this answer
The iPod doesn't get a drive letter assigned, it just shows up as a camera. Even when it did sync with the PC, it always worked this way, so that's not the problem. Thanks anyway! – alex Apr 6 '10 at 18:09

Sounds to me like maybe the drivers aren't working or are corrupt. What does your iPod do when you plug it in? Does it still charge and say that it's connected?

Try completely removing the drivers and let Windows 7 go out and redownload and reinstall the drivers.

share|improve this answer
I tried letting Windows reinstall the drivers; no luck, sadly. When plugging the iPod in, it starts charging, while Windows sees it and asks me what to do with it (it sees it as a camera, so I can see all photos on it). Also, iTunes definitely notices the iPod, since it completely locks up and is unresponsive until unplugging the iPod from the PC. I'm sure it's a driver problem, but I don't know how to solve it. I'll probably end up just waiting for iPhone OS 4.0 and a new version of iTunes; maybe that can solve the problem (doubt it). +1, anyway. Thanks! – alex Apr 6 '10 at 13:21

From the Apple support forums:

I pulled up the task manager and closed out "iTunes helper" and iTunes immediately recognized my iPod.

share|improve this answer

Try completely wiping your iPod on the device itself then reconnect. There may be something corrupt that the PC doesn't like.

share|improve this answer
That solved the problem. However, Matrix Mole's answer was a bit faster than yours. Thank you, anyway! +1 – alex Apr 8 '10 at 6:38
It's not a competition. Glad it solved your problem. – Mike Wills Apr 8 '10 at 13:00

Your Post says Windows 7, so this may not apply, but in XP I recently had to goto the Control Panel, Cameras and Scanners, and change the default action associated with the iPod from open with "Microsoft Office Scanner", to "Do Nothing" This solved my daughter's issue iTunes freezing during a sync. Don't know if this crosses over to Windows 7 though.

share|improve this answer
Already did that. – alex Apr 7 '10 at 4:55

I know this may sound a little non-techy, but I've had an iPod that failed to sync with my PC, and after updates and frustration I went to Apple and requested a new one. It turned out that the hard drive in the iPod was corrupt; the problem might not always be your PC.

If possible, return it. You could also try syncing on another PC (not Mac).

Try using a previous version of iTunes, and reformat it on there.

share|improve this answer
I can't send it back. It was bought in the US, but I live in Romania. Also, it's out of warranty. The lack of syncing with my PC bugs me, but it's not a major issue since I also have a Mac that I can use for syncing. – alex Apr 6 '10 at 18:06
did you try a previous verison of ITunes? – Mike Apr 7 '10 at 16:07

Probably stating the obvious here but, did you try:

  • A different cable?

  • A different USB port (preferably on the pc, not a hub).

share|improve this answer
I tried all the USB ports, don't worry. Unfortunately, I don't have another cable (it's also weird to have it working on a Mac, but not on a PC). – alex Apr 6 '10 at 18:07
Hmm, voted down for suggesting a basic troubleshooting step, how discouraging. I could understand it if the question had stated the same cable was used on Mac & PC. Oh well. – Chris Apr 7 '10 at 1:29

If it is able to sync on the Mac then my guess is that the iPod is not formatted to work with iTunes on a PC. They use different formatting and normally will prompt you to format it to work correctly on the Mac. If you have enabled disk use then a portion of the drive is Fat32 and that would explain why the PC sees it as a camera but iTunes can't read the library directory correctly.

--or some combination of the above but specifically related to the disk format.

It may work to reset the iPod back to factory defaults (since it is sync'd already with the Mac and you can pull the pictures off it manually, you shouldn't lose anything). I believe using the "Erase all content" in the settings will do this as well as holding the home and sleep buttons together. Once this is done then it just needs to be connected to iTunes again to be setup and reinitialized. At this point Win7 iTunes may pick it up and set it for sync.

share|improve this answer
It's an iPod Touch. What is there to format? It worked correctly; I had it synced with both my PC and my Mac. It's not really a formatting problem. Also, I had it restored (that's a complete OS reinstall, along with wiping of all content from the iPod). – alex Apr 6 '10 at 19:39
It is still a drive storing the data on the iPod and the drive has to be formatted for either PC or Mac. Format of the iPod touch drive still matters. If you did a restore that should have reset the device, as I mentioned, but if you perform the restore on a Mac the iPod touch drive will be formatted as HFS+ which Windows cannot read. If you wipe the device FROM the device, then the Win7 installation will see a "blank" iPod and may allow you to Restore using the PC which will make the iPod usable on the Windows machine - but no longer sync on Mac (only 1 sync device allowed per iPod). – Insomnic Apr 7 '10 at 16:20

When you install iTunes it installs a USB driver for the iPod. I would look in Device Manager and when the iPod is plugged in, see if you can roll back the driver.

Another option may be to back up your iTunes library, uninstall iTunes and then reinstall the latest version. Make sure that the device drivers and all services are deleted.

You may also want to run the iPod diagnostics from the "Help" menu. Since iTunes isn't running on your PC with the thing plugged in, run the diagnostics on your Mac.

If you're out of ideas, try and see where iTunes is hanging (is it a system call or one of its own?) - use Process Explorer. This article should give you a good start on how to use it.

share|improve this answer
Tried all of that. Installed, uninstalled, rollbacked, deleted, reinstalled, updated, you name it, I've tried it. – alex Apr 8 '10 at 6:09
You've tried Process Explorer to see where it is hanging? – Apr 8 '10 at 9:37

I have tried every fix suggested here and elsewhere but this is the only one that worked for me: changing the iTunes files/executables into XP compatibility mode.

I'm running the latest iTunes on Windows Vista and connecting an iPod Touch.

I went into Task Manager (Ctrl+Alt+Delete) and located most of the services/processes. I then right clicked on each of them, and selected Properties → Compatibility.

For each service I changed the compatibility mode to "Windows XP". Some, but not all of the files, include ipodservce, itunesservice, syncserver, helper and so on.

Do NOT change the setting on itunes.exe, or it will fail. Since I made these changes iTunes has worked for me.

share|improve this answer

you could try other ipod managers:

atunes, sharepod, floola

more alternatives here

share|improve this answer
From the question: "I've also tried using MediaMonkey and DoubleTwist. None of these apps see the iPod as being connected; DoubleTwist also freezes, just like iTunes". It's not an app issue, trust me. – alex Apr 6 '10 at 13:22
i also had similar problems on linux managers, and gtkpodder worked for me, that is why i sugested trying other managers – Gabriel Solomon Apr 7 '10 at 10:38

From the Apple support forums:

Just delete any PODCASTS that you have on your iPhone/iPod. Then try again.

Seems to have worked for a lot of folks.

share|improve this answer
I don't have any podcasts (I did a restore so there's nothing on it). – alex Apr 6 '10 at 18:08

Starting from Crash's idea: if that is the case, you can:

  1. Open a Command Prompt
  2. Type diskpart
  3. Type list disk
  4. Type select disk $ ($ is the istuff disk number)
  5. Type select partition 1
  6. Type assign

A drive letter will be assigned. Otherwise you could try Start -> right click on Computer -> Manage, then check the storage stuff.

share|improve this answer
See my comment from Crash's answer. – alex Apr 6 '10 at 18:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .