Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got 2 pcs setup with WLAN - however when I copy files between the machines it takes forever (obviously, since I run 801.11g).

So I thought, why not just connect them directly with a cable (my wireless router is the other end of the house, that's why I don't use cables to that)

However how should I configure the LAN connection on each machine, so I can use it for transferring files between them, whilst using my WLAN to access the Internet ?

I was thinking about letting one machine be gateway, but then Windows pops up with a lot of warnings (basically it says this won't work when you're using two disjoint networks)

And now I'm at a loss as to what to try.

share|improve this question

3 Answers 3

up vote 3 down vote accepted

I've connected Windows computers and servers directly together using static IP addresses like this:

Machine 1:

IP Address: 10.0.0.1
Subnet mask: 255.255.255.0
Default gateway: (blank)

Machine 2:

IP Address: 10.0.0.2
Subnet mask: 255.255.255.0
Default gateway: 10.0.0.1

(You may need to choose a different subnet if 10.0.0.X is already used for another network.)

Disconnect the cable that will be used to directly connect the machines.

On each machine:

  1. Type ncpa.cpl at the command prompt.

  2. Double-click on the network adapter that will connect via the cable.

  3. Double-click Internet Protocol (TCP/IP) to edit properties. [Use IPV4 on Windows 7/Vista]

  4. Select Use the following IP address.

  5. Enter the machine's IP Address, Subnet Mask and Default Gateway.

  6. OK out.

When both machines have been configured, plug the cable into the network adapters. The URLs \\10.0.0.1\ and \\10.0.0.2\ should now allow access to shared folders on the machines.

I use this method to connect my Windows 7 machines to a Windows Home Server by setting the server up like machine 1. It saves a lot of time for large backups!

share|improve this answer
    
I tried that as well however Windows then opts to use this connection for Internet access as well (which it shouldn't, since there's no Internet available on this one) I guess there's no easy way to switch two network adapters on at the same time :-( –  Steffen Apr 1 '10 at 20:18
    
Not sure why you're getting this problem. I just followed this procedure and am replying using a Win 7 machine that's transferring files from another PC via Ethernet cable on 10.0.0.X subnet while it's also connected wirelessly to the internet on 192.168.0.X subnet. This didn't require any extra routes to be set up. Can you access the other PC on 10.0.0.1 or 10.0.0.2? (Pinging may require a new firewall rule to respond to the ICMP packet.) –  Jonathan Webb Apr 1 '10 at 20:41
    
You shouldn't set a default gateway on Machine 2. Without that it won't try to use that connection for the Internet, but it will still connect to 10.0.0.1 because of the subnet mask. –  shf301 Apr 3 '10 at 0:47
    
Hmmm yea this is very weird, since it works for you. It was actually the 10.0.0.1 machine which dropped the Internet access - probably because it figured it was its own gateway (just a guess) Anyway I've pretty much given up on it, I'm just gonna buy a N router instead of my G, and live with WLAN. –  Steffen Apr 3 '10 at 6:17
    
@shf301 Setting or clearing the 10.0.0.1 default gateway on Machine 2 seems to make no difference on my Win 7 machine. Either way I'm able to release and renew the wireless internet connection while still connected to Machine 1. Is this just down to luck with the route table? –  Jonathan Webb Apr 3 '10 at 11:26

If just you're transferring files from machine to machine, turn off one of the machines' wireless adapter, forcing that path to use ethernet.

share|improve this answer
    
True I could do that, however since one of my machines belong to my girlfriend (and she's hardly a "nerd") this approach isn't viable in practice :-/ I think I'll resort to upgrading my WLAN to N instead of G, that should help a bit (300 mbit vs. 54) –  Steffen Apr 1 '10 at 20:19

I am using the following approach on Windows Vista.

  1. set up computer A using wireless to your router.
  2. connect computer B to computer A over Ethernet (wired)

Then on computer A choose "Start" -> "Settings" -> "Network Connections". Click on your wireless connection, then press ctrl-click on your Ethernet Local Area Connection; once these two interfaces have been highlighted choose "Create Network Bridge" after right clicking.

Now both computer A and computer B are sharing the wireless interface on computer A.

If you are using a consumer router then you may want to configure computer B with a static IP address (because its DHCP request will look identical to computer A's DHCP request as they come from the same wireless interface). So if computer A is assigned 192.168.0.3, for example, set computer B to 192.168.0.23 (you will have to play with this until you get a free IP).

Note that this technique always requires computer A to be on if you want computer B to access your wireless router.

share|improve this answer
    
This might do the trick, though it's not exactly why I want to do it :-) Both machines are connected to the WLAN through their own wireless network adapter. I just want to connect them directly together through cable (gigabit) to make file copying faster. But I'll try bridging the adapters and see if that works. –  Steffen Apr 1 '10 at 8:27
    
Well that didn't work out the way I had hoped :-( I basically just got an "unidentified network" on the bridge, and couldn't connect through it :-/ –  Steffen Apr 1 '10 at 8:37
    
@Steffen I'm sorry this didn't work for you –  PP. Apr 1 '10 at 14:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.